Bug 1304865 - /usr/lib64/libreadline-java/libreadline-java.jar is a stale symbolic link
/usr/lib64/libreadline-java/libreadline-java.jar is a stale symbolic link
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreadline-java (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: gil cattaneo
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 15:07 EST by Roy A. Gilmore
Modified: 2016-02-17 14:41 EST (History)
3 users (show)

See Also:
Fixed In Version: libreadline-java-0.8.0-42 libreadline-java-0.8.0-42.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-14 21:52:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roy A. Gilmore 2016-02-04 15:07:21 EST
Description of problem:


Version-Release number of selected component (if applicable):
libreadline-java-0.8.0-38.fc22.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Install libreadline-java-0.8.0-38.fc22.x86_64

Actual results:
/usr/lib64/libreadline-java/libreadline-java.jar is a stale symbolic link to the nonexistent file ../java/libreadline-java.jar

Expected results:
/usr/lib64/libreadline-java/libreadline-java.jar to be a valid symbolic link

Additional info:
/usr/lib64/libreadline-java/libreadline-java.jar should be a symbolic link to ../../lib/java/libreadline-java.jar
Comment 1 Fedora Update System 2016-02-04 16:42:03 EST
libreadline-java-0.8.0-42.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5acd868ee7
Comment 2 Fedora Update System 2016-02-05 18:51:22 EST
libreadline-java-0.8.0-42.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5acd868ee7
Comment 3 Fedora Update System 2016-02-14 21:52:48 EST
libreadline-java-0.8.0-42.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 4 Roy A. Gilmore 2016-02-15 16:41:04 EST
Pushing it to Fedora 23 doesn't help the people that are running Fedora 22. If I wanted a fix for Fedora 23, I would have  filed the bug against Fedora 23. I guess it doesn't matter, as I'm looking for a new distribution, because Fedora has made several changes that have made Fedora more Windows-like and less Unix-like (apparently) to appeal to gamers and other standalone users, has dropped a lot of networking support, doesn't update the documentation, and hasn't been worth a crap as a server distribution since Fedora 14.
Comment 5 gil cattaneo 2016-02-17 13:10:20 EST
(In reply to Roy A. Gilmore from comment #0)

> Actual results:
> /usr/lib64/libreadline-java/libreadline-java.jar is a stale symbolic link to
> the nonexistent file ../java/libreadline-java.jar
> 
> Expected results:
> /usr/lib64/libreadline-java/libreadline-java.jar to be a valid symbolic link
> 
> Additional info:
> /usr/lib64/libreadline-java/libreadline-java.jar should be a symbolic link
> to ../../lib/java/libreadline-java.jar
No, this will never happen
The artifact is installed in /usr/lib/java (%{_jnidir})
see https://fedoraproject.org/wiki/Packaging:Java#Packaging_JAR_files_that_use_JNI
Comment 6 gil cattaneo 2016-02-17 13:14:55 EST
For the rest, your considerations do not matter to anyone. keep them for yourself or for your cronies spree. Thanks.
Comment 7 Roy A. Gilmore 2016-02-17 14:41:05 EST
(In reply to gil cattaneo from comment #5)
> (In reply to Roy A. Gilmore from comment #0)
> 
> > Actual results:
> > /usr/lib64/libreadline-java/libreadline-java.jar is a stale symbolic link to
> > the nonexistent file ../java/libreadline-java.jar
> > 
> > Expected results:
> > /usr/lib64/libreadline-java/libreadline-java.jar to be a valid symbolic link
> > 
> > Additional info:
> > /usr/lib64/libreadline-java/libreadline-java.jar should be a symbolic link
> > to ../../lib/java/libreadline-java.jar
> No, this will never happen
> The artifact is installed in /usr/lib/java (%{_jnidir})
> see
> https://fedoraproject.org/wiki/Packaging:
> Java#Packaging_JAR_files_that_use_JNI

The example I gave is (from a filesystem view) a valid location for the target of the symbolic link. I don't really care about packaging policy, that is an administrative detail that is important to packagers (and should be), not users. What I do care about, is that a broken symbolic link should not exist in a released package, and should have been caught by QA. Where that link actually points may very well be a policy issue, but, the target should exist regardless.

Note You need to log in before you can comment on or make changes to this bug.