Bug 1304866 - oc get projects should return sorted list of projects
oc get projects should return sorted list of projects
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Fabiano Franz
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 15:16 EST by Vikas Laad
Modified: 2016-07-04 18:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-04 18:07:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikas Laad 2016-02-04 15:16:51 EST
Description of problem:
Create multiple projects and try to run go get projects, often list displayed is not sorted by name. It should be sorted by name.

Version-Release number of selected component (if applicable):


How reproducible:
Often

Steps to Reproduce:
1. oc new-project aaa
2. oc new-project bbb
3. oc new-project ccc
4. oc new-project ddd
5. oc new-project eee
6. oc get projects

Actual results:
Often the result returned is not sorted by name
NAME      DISPLAY NAME   STATUS
ccc                      Active
ddd                      Active
eee                      Active
aaa                      Active
bbb                      Active


Expected results:
Result should be always sorted by name
NAME      DISPLAY NAME   STATUS
aaa                      Active
bbb                      Active
ccc                      Active
ddd                      Active
eee                      Active


Additional info:
Comment 1 Fabiano Franz 2016-07-04 18:07:27 EDT
The output of `get` isn't supposed to be deterministic by design. The --sort-by flag is provided to allow sorting. Also, `oc projects` is a more end-user targeted command to list project, and displays projects sorted by name.

Note You need to log in before you can comment on or make changes to this bug.