Bug 1304896 - Calc fails import 'special characters' correctly
Calc fails import 'special characters' correctly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eike Rathke
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 18:01 EST by morgan read
Modified: 2016-02-05 15:39 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-05 07:00:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
original text file (2.41 KB, text/plain)
2016-02-04 18:01 EST, morgan read
no flags Details
first pass with 'detect special numbers' flag (219.90 KB, image/png)
2016-02-04 18:03 EST, morgan read
no flags Details
second pass without 'detect special numbers' flag (222.85 KB, image/png)
2016-02-04 18:05 EST, morgan read
no flags Details
third pass with 'detect special numbers' again with quotation marks (223.34 KB, image/png)
2016-02-04 18:07 EST, morgan read
no flags Details
first pass again with 'detect special numbers' flag _after restart_ (219.90 KB, image/png)
2016-02-04 18:10 EST, morgan read
no flags Details
resulting Calc speadsheet with quotation marks (255.72 KB, image/png)
2016-02-04 18:11 EST, morgan read
no flags Details

  None (edit)
Description morgan read 2016-02-04 18:01:27 EST
Created attachment 1121229 [details]
original text file

Description of problem:
Calc doesn't interpret 'quoted field as text' / 'detect special numbers' properly - quotation marks are detected on first run but then not detected on a second run - also, they are not imported properly - quotation marks for text detected in the Text Import tool are not striped in the resulting Calc sheet - see attached images (taking note of the 'detect special numbers' check box and the time sequence of the images)

Version-Release number of selected component (if applicable):
$ rpm -qa libreoffice
libreoffice-4.4.7.2-1.fc22.x86_64

How reproducible:
seems reproducible, restarting libreoffice seems to 're-set' so that quotes are detected - then importing a second time, they're not detected 

Steps to Reproduce:
1. import text file with quotation marks defining text fields
2. see above and attached images
3.

Actual results:
intermittent detection of quotation marks for text fields and failure to reflect them in resulting Calc sheets

Expected results:
consistent interpretation of quotation marks for text fields properly reflected in Calc sheets

Additional info:
see attached original text files and images images
Comment 1 morgan read 2016-02-04 18:03 EST
Created attachment 1121230 [details]
first pass with 'detect special numbers' flag
Comment 2 morgan read 2016-02-04 18:05 EST
Created attachment 1121231 [details]
second pass without 'detect special numbers' flag
Comment 3 morgan read 2016-02-04 18:07 EST
Created attachment 1121246 [details]
third pass with 'detect special numbers' again with quotation marks
Comment 4 morgan read 2016-02-04 18:10 EST
Created attachment 1121247 [details]
first pass again with 'detect special numbers' flag _after restart_
Comment 5 morgan read 2016-02-04 18:11 EST
Created attachment 1121248 [details]
resulting Calc speadsheet with quotation marks
Comment 6 Eike Rathke 2016-02-05 07:00:51 EST
Note that in the screen shots the "Text delimiter" field is empty, it should have selected the " quote character instead then it works.
Comment 7 morgan read 2016-02-05 15:39:18 EST
Oh bottom, missed something obvious again!

But why are these things showing up now?  I've just gone to f22, been using lo (and before that oo, and before that so) for the past 15 years - have all the defaults been reset from lo4-5/ f20-22?

Note You need to log in before you can comment on or make changes to this bug.