Bug 1304897 - When gnome is started using startx, it no longer honors the ~/.Xkbmap file
When gnome is started using startx, it no longer honors the ~/.Xkbmap file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-desktop3 (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 18:02 EST by stan
Modified: 2016-03-09 10:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 10:33:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stan 2016-02-04 18:02:37 EST
Description of problem:
I boot into multiuser in rawhide, f24 to be.  I then use startx with
GSESSION="$(type -p gnome-session)" in ~/.Xclients to start Gnome.  When Gnome comes up, it is using the US qwerty keyboard, even though I have ~/.Xkbmap with my custom keymapping in it, and that keymapping is in the right place.  Other desktops that I start using this method have no trouble finding and using that custom keymap on start.  Well, KDE crashes here in rawhide, so I couldn't test it, but xfce, cinnamon, mate, lxde all used the correct keymap.

Version-Release number of selected component (if applicable):
I'm not in rawhide right now, but it is the latest version in the repositories as of 2016-02-02

How reproducible:
Every time.

Steps to Reproduce:
1.  Run rawhide
2.  Put keymap in ~/.Xkbmap, put GSESSION="$(type -p gnome-session)" in ~/.Xclients
3.  Run startx

Actual results:
Gnome starts with us qwerty keyboard

Expected results:
Gnome starts with keymapping in ~/.Xkbmap

Additional info:
I don't think this is running Wayland since I'm not running the greeter to start Gnome, unless it is being invoked behind the scenes (that is, Gnome always defaults to wayland, and ignores X configuration).

The selector in Gnome doesn't show the custom keymap in order to switch to it.  I've been using the custom keymap so long that even though I was a fast touch typist with qwerty, I'm lost now when I have to use it, hunt and peck.
Comment 1 Jan Kurik 2016-02-24 09:24:43 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 stan 2016-03-09 10:33:45 EST
This is no longer the case in rawhide (f25).  So I am closing the ticket.

Note You need to log in before you can comment on or make changes to this bug.