Bug 130496 - Poor TCP performance with usbnet driver
Poor TCP performance with usbnet driver
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-20 15:43 EDT by Paul Black
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 16:14:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Extract of ethereal capture for working case (8.85 KB, text/plain)
2004-08-20 15:44 EDT, Paul Black
no flags Details
Extract of ethereal capture for non-working case (64.04 KB, text/plain)
2004-08-20 15:44 EDT, Paul Black
no flags Details

  None (edit)
Description Paul Black 2004-08-20 15:43:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
Upgrading my FC2 kernel from 2.6.5-1.358 to 2.6.8-1.521 has caused
poor performance on TCP when browsing certain websites (using Firefox)
with my cable modem (Ambit). I'm not sure when the problem appeared
because 2.6.5-1.358 was the last kernel where my ethernet (nvidia)
worked until now. An ethereal capture shows the TCP window for the
working case increasing but not for the non-working case.


Version-Release number of selected component (if applicable):
2.6.8-1.521

How reproducible:
Always

Steps to Reproduce:
1. Go to http://www.ebay.co.uk and get a page with "a lot" on it. In
my case, it's my standard eBay page but a search page should have the
same symptoms. In may case, I'm using Firefox (will try others later).


Actual Results:  Expect webpage to load promptly.

Expected Results:  Web page is extremely slow to load.

Additional info:
Comment 1 Paul Black 2004-08-20 15:44:20 EDT
Created attachment 102937 [details]
Extract of ethereal capture for working case
Comment 2 Paul Black 2004-08-20 15:44:53 EDT
Created attachment 102938 [details]
Extract of ethereal capture for non-working case
Comment 3 David Miller 2004-08-20 15:50:23 EDT
Try: echo "0" >/proc/sys/net/ipv4/tcp_default_win_scale

If that fixes it, the problem is in either a router or
firewall between your host and the remote web site.
It is not a bug in Linux.
Comment 4 Paul Black 2004-08-20 16:14:57 EDT
That does the job. Cheers.

Note You need to log in before you can comment on or make changes to this bug.