Bug 1304985 - libtoolize fails
libtoolize fails
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libtool (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Raiskup
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-05 03:23 EST by Akira TAGOH
Modified: 2016-02-05 07:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-05 07:30:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2016-02-05 03:23:35 EST
Description of problem:
When running libtoolize, fails as:
libtoolize: putting auxiliary files in '.'.
libtoolize: copying file './ltmain.sh'
/usr/bin/libtoolize: eval: line 3772: unexpected EOF while looking for matching `"'
/usr/bin/libtoolize: eval: line 3773: syntax error: unexpected end of file

Version-Release number of selected component (if applicable):
libtool-2.4.6-8.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1.run libtoolize
2.
3.

Actual results:
fails

Expected results:
should be done without any errors

Additional info:
Comment 1 Akira TAGOH 2016-02-05 03:47:34 EST
Hm, okay. tracked this down. it happens when Makefile.am has:
ACLOCAL_AMFLAGS = \
 ...

if it is one liner, works fine. I think it worked before. dunno what version it is. at least on f22.
Comment 2 Pavel Raiskup 2016-02-05 04:58:40 EST
Thanks for the report, reproduced.  It probably did not work correctly before
either (the ACLOCAL_AMFLAGS did not parse '-I' option correctly).  Previously
libtoolize just did not complain.  So as a workaround, please specify only
one-line ACLOCAL_AMFLAGS.
Comment 3 Pavel Raiskup 2016-02-05 07:30:35 EST
As there is AC_CONFIG_MACRO_DIR[S] in autoconf, the ACLOCAL_AMFLAGS should be
less needed in future.  It is still needed nowadays, but it is not much useful
to hack on it right now.  So please let me close this as WONTFIX with
workaround discussed before -- kee ACLOCAL_AMFLAGS on single line.  It is
already documented in auto(re)conf's manual [1]:

      If you want autoreconf to pass flags that are not listed here on to
      aclocal, set ACLOCAL_AMFLAGS in your Makefile.am. Due to a limitation in
      the Autoconf implementation these flags currently must be set on a
      single line in Makefile.am, without any backslash-newlines.

[1] https://www.gnu.org/savannah-checkouts/gnu/autoconf/manual/autoconf-2.69/html_node/autoreconf-Invocation.html#autoreconf-Invocation

Note You need to log in before you can comment on or make changes to this bug.