Bug 130500 - Shared objects not installed properly
Shared objects not installed properly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lesstif (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-20 16:08 EDT by Jeff Ludwig
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 08:02:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Ludwig 2004-08-20 16:08:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
It seems the rpm install is not sym-linking the shared objects
properly.   My system installed without a symbolic link between
libXm.so.1 and libXm.so... this causes an autoconf macro such as:

AC_CHECK_LIB(Xm, XmStringCreate,
        XM_LIBS="-lXm"
        AC_DEFINE(HAVE_MOTIF, 1), AC_DEFINE(HAVE_MOTIF, 0),
        ${X_PRE_LIBS} ${XPM_LIBS} ${XEXT_LIBS} ${XT_LIBS} ${XEXT_LIBS}
${X11_LIBS})

to bail out... I noticed this for other libraries, libjpeg.so.62 for
instance.

Version-Release number of selected component (if applicable):
0.93.36-5.2

How reproducible:
Didn't try

Steps to Reproduce:
1. Check /usr/X11R6/lib for proper links
2.
3.
    

Additional info:
Comment 1 Thomas Woerner 2004-08-23 08:02:14 EDT
lesstif is in Fedora Core only for copatibility reasons. If you want
to compile Motif applications, then use openmotif and openmotif-devel.

Closing as "NOT A BUG".

Note You need to log in before you can comment on or make changes to this bug.