Bug 1305073 - hardware.py crashed while executing ipa-upgarde test execution
hardware.py crashed while executing ipa-upgarde test execution
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomáš Kašpárek
Red Hat Satellite QA List
:
: 1305740 (view as bug list)
Depends On:
Blocks: 1306715
  Show dependency treegraph
 
Reported: 2016-02-05 09:21 EST by Nikhil Dehadrai
Modified: 2016-05-27 03:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-24 04:24:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikhil Dehadrai 2016-02-05 09:21:16 EST
Description of problem:
hardware.py crashed while executing ipa-upgarde test execution.

How reproducible:
Always

Steps to Reproduce:
1. Setup IPA server for ipa-upgrade test suite execution on beaker. 
2. Make sure latest repo links are set correctly for test execution.
3. Initiate automation for ipa-upgrade test suite on beaker.

Once the automation for ipa-upgrade is complete, following message is received.

Actual results:

backtrace:
:hardware.py:45:<module>:ImportError: No module named hardware_hal
:
:Traceback (most recent call last):
:  File "/usr/share/rhn/up2date_client/hardware.py", line 45, in <module>
:    from hardware_hal import check_hal_dbus_status, get_hal_computer, read_hal
:ImportError: No module named hardware_hal
:
:Local variables in innermost frame:
:AF_INET6: 10
:getaddrinfo: <built-in function getaddrinfo>
:rhnserver: <module 'rhnserver' from '/usr/share/rhn/up2date_client/rhnserver.pyc'>
:gethostname: <built-in function gethostname>
:up2dateLog: <module 'up2dateLog' from '/usr/share/rhn/up2date_client/up2dateLog.pyc'>
:gettext: <module 'gettext' from '/usr/lib64/python2.7/gettext.pyc'>
:__package__: None
:re: <module 're' from '/usr/lib64/python2.7/re.pyc'>
:config: <module 'config' from '/usr/share/rhn/up2date_client/config.pyc'>
:__doc__: 'Used to read hardware info from kudzu, /proc, etc'
:ethtool: <module 'ethtool' from '/usr/lib64/python2.7/site-packages/ethtool.so'>
:__builtins__: <module '__builtin__' (built-in)>
:__file__: '/usr/share/rhn/up2date_client/hardware.py'
:sys: <module 'sys' (built-in)>
:dmidecode: <module 'dmidecode' from '/usr/lib64/python2.7/site-packages/dmidecode.pyc'>
:ethtool_present: True
:__name__: '__main__'
:_: <bound method NullTranslations.ugettext of <gettext.NullTranslations instance at 0x18d4998>>
:socket: <module 'socket' from '/usr/lib64/python2.7/socket.pyc'>
:dbus: <module 'dbus' from '/usr/lib64/python2.7/site-packages/dbus/__init__.pyc'>
:AF_INET: 2
:t: <gettext.NullTranslations instance at 0x18d4998>
:os: <module 'os' from '/usr/lib64/python2.7/os.pyc'>


Expected results:
No Crash reports should be observed for testing ipa-upgrade test suite.

Additional info:
This crash was observed while performing automation upgrade testing from RHEL 7.0 > RHEL 7.2.z (up2).
Comment 2 Tomas Lestach 2016-02-17 08:46:50 EST
I'm sorry, but it's not quite clear, what is ipa-upgrade and how rhn-client-tools are called.
Could we get a minimal reproducer, how to call rhn-client-tools to get this traceback?
Comment 3 Nikhil Dehadrai 2016-02-24 01:59:00 EST
I have attached the crash logs received for the system that reproduced similar error message.

Let me know if you need any more information.
Comment 5 Tomas Lestach 2016-02-24 04:24:58 EST
According to the provided crash log, it looks hardware.py is called in the following way:
 # python /usr/share/rhn/up2date_client/hardware.py

This is definitely not supported. You're supposed to call only rhn-client-tools utilities from /usr/bin/ and /user/sbin/. CLosing as NOTABUG.
Comment 6 Tomas Lestach 2016-03-09 08:02:08 EST
*** Bug 1305740 has been marked as a duplicate of this bug. ***
Comment 7 Hai Nguyen 2016-05-26 16:23:55 EDT
I don't see a resolution for this. Would you please provide more information as how to deal with these crashes?
Comment 8 Tomas Lestach 2016-05-27 03:50:08 EDT
Making Comment 5 publicly readable.

Note You need to log in before you can comment on or make changes to this bug.