Bug 1305175 - FileNotFoundError: [Errno 2] No such file or directory: '/run/firewalld/temp.70tej_w7'
FileNotFoundError: [Errno 2] No such file or directory: '/run/firewalld/temp....
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-05 17:39 EST by Brian Lane
Modified: 2016-02-08 08:30 EST (History)
2 users (show)

See Also:
Fixed In Version: firewalld-0.4.0-3.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-08 08:30:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2016-02-05 17:39:01 EST
Running firewall-offline-cmd in the anaconda boot.iso environment results in a traceback:

22:11:18,230 INFO program: Running... /usr/bin/firewall-offline-cmd --enabled --service=ssh --service=mdns
22:11:18,632 INFO program: ERROR: Failed to create temporary file: [Errno 2] No such file or directory: '/run/firewalld/temp.70tej_w7'
22:11:18,633 INFO program: Traceback (most recent call last):
22:11:18,633 INFO program: File "/usr/bin/firewall-offline-cmd", line 33, in <module>
22:11:18,633 INFO program: from firewall.core.fw_test import Firewall_test
22:11:18,634 INFO program: File "/usr/lib/python3.5/site-packages/firewall/core/fw_test.py", line 29, in <module>
22:11:18,634 INFO program: from firewall.core.fw_direct import FirewallDirect
22:11:18,634 INFO program: File "/usr/lib/python3.5/site-packages/firewall/core/fw_direct.py", line 27, in <module>
22:11:18,634 INFO program: from firewall.core import ebtables
22:11:18,635 INFO program: File "/usr/lib/python3.5/site-packages/firewall/core/ebtables.py", line 215, in <module>
22:11:18,635 INFO program: ebtables_available_tables = ebtables().available_tables()
22:11:18,635 INFO program: File "/usr/lib/python3.5/site-packages/firewall/core/ebtables.py", line 56, in __init__
22:11:18,635 INFO program: self.restore_noflush_option = self._detect_restore_noflush_option()
22:11:18,635 INFO program: File "/usr/lib/python3.5/site-packages/firewall/core/ebtables.py", line 77, in _detect_restore_noflush_option
22:11:18,636 INFO program: self.set_rules(rules, flush=False)
22:11:18,636 INFO program: File "/usr/lib/python3.5/site-packages/firewall/core/ebtables.py", line 94, in set_rules
22:11:18,636 INFO program: temp_file = tempFile()
22:11:18,636 INFO program: File "/usr/lib/python3.5/site-packages/firewall/functions.py", line 269, in tempFile
22:11:18,637 INFO program: dir=FIREWALLD_TEMPDIR, delete=False)
22:11:18,637 INFO program: File "/usr/lib64/python3.5/tempfile.py", line 549, in NamedTemporaryFile
22:11:18,637 INFO program: (fd, name) = _mkstemp_inner(dir, prefix, suffix, flags, output_type)
22:11:18,637 INFO program: File "/usr/lib64/python3.5/tempfile.py", line 260, in _mkstemp_inner
22:11:18,637 INFO program: fd = _os.open(file, flags, 0o600)
22:11:18,638 INFO program: FileNotFoundError: [Errno 2] No such file or directory: '/run/firewalld/temp.70tej_w7'
22:11:18,638 DEBUG program: Return code: 1


Looks like /run/firewalld/ doesn't exist and it assumes it is there instead of checking and creating it.


This is with firewalld-0.4.0-1.fc24

Note You need to log in before you can comment on or make changes to this bug.