Bug 130518 - gpm startup too optimistic
gpm startup too optimistic
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gpm (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-20 19:08 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 14:53:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-08-20 19:08:09 EDT
Description of problem:

Something decided to disappear my /dev/input/mice which is
configured as DEVICE="/dev/input/mice" in my /etc/sysconfig/gpm.
Still

# service gpm start
Starting console mouse services:                           [  OK  ]

but immediately after that

# service gpm status
gpm dead but pid file exists

Eh?  This was supposedly "OK".

Version-Release number of selected component (if applicable):
gpm-1.20.1-50

How reproducible:
100%
Comment 1 Eido Inoue 2004-09-23 14:53:38 EDT
The startup did succeed, but it failed afterwards because of the lack
of file. Unfortunately, gpm doesn't test that everything is in order
before returning to the shell... and the delay needed to wait for
failure can be significant.

Note You need to log in before you can comment on or make changes to this bug.