Bug 130520 - Leak in the menu method
Leak in the menu method
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-20 19:28 EDT by Kjartan Maraas
Modified: 2013-04-02 00:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 09:05:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2004-08-20 19:28:24 EDT
Description of problem:
Valgrind reports this when using the latest gnome-panel and gnome-vfs2
from rawhide today:

==4503== 35012 bytes in 356 blocks are definitely lost in loss record
222 of 230
==4503==    at 0x1B903419: calloc (vg_replace_malloc.c:176)
==4503==    by 0xCC998F: g_malloc0 (in /usr/lib/libglib-2.0.so.0.400.6)
==4503==    by 0x1C296340: entry_set_new (menu-entries.c:937)
==4503==    by 0x1C29DB82: ??? (menu-process.c:434)
==4503==    by 0x1C29D90D: ??? (menu-process.c:602)
==4503==    by 0x1C29D90D: ??? (menu-process.c:602)
==4503==    by 0x1C29E38A: ??? (menu-process.c:84)
==4503==    by 0x1C29E7C2: ??? (menu-process.c:162)
==4503==    by 0x1C29D94E: ??? (menu-process.c:185)
==4503==    by 0x1C29D90D: ??? (menu-process.c:602)
==4503==    by 0x1C29D90D: ??? (menu-process.c:602)
==4503==    by 0x1C29D90D: ??? (menu-process.c:602)
==4503==    by 0x1C29E38A: ??? (menu-process.c:84)
==4503==    by 0x1C29E7C2: ??? (menu-process.c:162)
==4503==    by 0x1C29D94E: ??? (menu-process.c:185)
==4503==    by 0x1C29D90D: ??? (menu-process.c:602)
==4503==    by 0x1C29D90D: ??? (menu-process.c:602)
==4503==    by 0x1C2A0AA9: desktop_entry_tree_load (menu-process.c:1108)
==4503==    by 0x1C2A2699: ??? (menu-tree-cache.c:137)
==4503==    by 0x1C2A28ED: desktop_entry_tree_cache_lookup
(menu-tree-cache.c:371)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kjartan Maraas 2005-02-02 09:05:15 EST
Closing this since this menu method is being replaced by a new
implementation of the menu spec.

Note You need to log in before you can comment on or make changes to this bug.