Bug 1305204 - qemu-dm process crash in Fedora23 kernel-4.3.4
qemu-dm process crash in Fedora23 kernel-4.3.4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-05 21:45 EST by yuxisun@redhat.com
Modified: 2016-09-27 04:12 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-27 04:09:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
qemu-dm core dump (401.86 KB, application/x-xz)
2016-02-05 22:19 EST, Wei Shi
no flags Details

  None (edit)
Description yuxisun@redhat.com 2016-02-05 21:45:54 EST
Description of problem:
qemu-dm process crash after creating a PV/HVM guest in Fedora23(kernel-4.3.4-300.fc23.x86_64)
For HVM guest, qemu-dm process will crash in 10-30s.
For PV guest, qemu-dm process will crash in several minutes. 

Version-Release number of selected component (if applicable):
kernel-4.3.4-300.fc23.x86_64
xen-4.5.2-7.fc23.x86_64 

How reproducible:
Always

Steps to Reproduce:
1. Install a Fedora23 Server release version(kernel-4.2.3) through PXE on the host. 
2. yum install kernel-4.3.4, grub2-mkconfig -o /boot/grub2/grub.cfg
3. yum install xen, grub2-mkconfig -o /boot/grub2/grub.cfg, reboot host. Choose "Fedora, with Xen hypervisor" kernel.
4. Boot an existed guest (hvm img).
5. ps aux|grep qemu-dm, observe the process status for about 30s.
6. ls /var/lib/systemd/coredump/ , there's a qemu-dm core file in this folder. 

Actual results:
qemu-dm process crash in 10-30s. 

Expected results:
qemu-dm process works well. 

Additional info:
1. The kernel-4.2.3-300(with xen-4.5.2-7) doesn't have this issue. 
2. core file: core.qemu-dm.0.14e470d3ea5f430c967921b646a0bfc4.4956.1454663225000000.xz 
3. Host: ibm-x3650m3-08.lab.eng.pek2.redhat.com
Comment 1 Wei Shi 2016-02-05 22:19 EST
Created attachment 1121562 [details]
qemu-dm core dump
Comment 2 Laura Abbott 2016-09-23 15:55:34 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 3 Lin Liu 2016-09-27 04:09:12 EDT
Cannot reproduce this issue with Fedoar23 kernel-4.2.3-300 updated to 4.7.4-100.fc23. 
1. Creating a guest using xl configure file with device_model = "/usr/lib64/xen/bin/qemu-dm", the qemu process uses "/usr/bin/qemu-system-i386". Qemu process doesn't crash.
2. Creating a guest using virsh xml file with "<emulator>/usr/lib64/xen/bin/qemu-dm</emulator>", the qemu process uses qemu-dm, and qemu process doesn't crash either.
So close this bug.

Note You need to log in before you can comment on or make changes to this bug.