Bug 1305318 - [abrt] espeak: wave_write(): espeak killed by SIGABRT
[abrt] espeak: wave_write(): espeak killed by SIGABRT
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: espeak (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:f202245ad4b84836ecdd99dcc34...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-06 21:37 EST by jamie
Modified: 2016-02-08 19:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-08 04:52:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (14.54 KB, text/plain)
2016-02-06 21:37 EST, jamie
no flags Details
File: cgroup (200 bytes, text/plain)
2016-02-06 21:37 EST, jamie
no flags Details
File: core_backtrace (5.16 KB, text/plain)
2016-02-06 21:37 EST, jamie
no flags Details
File: dso_list (4.00 KB, text/plain)
2016-02-06 21:37 EST, jamie
no flags Details
File: environ (3.96 KB, text/plain)
2016-02-06 21:37 EST, jamie
no flags Details
File: limits (1.29 KB, text/plain)
2016-02-06 21:37 EST, jamie
no flags Details
File: maps (19.14 KB, text/plain)
2016-02-06 21:37 EST, jamie
no flags Details
File: mountinfo (3.36 KB, text/plain)
2016-02-06 21:37 EST, jamie
no flags Details
File: namespaces (85 bytes, text/plain)
2016-02-06 21:37 EST, jamie
no flags Details
File: open_fds (140 bytes, text/plain)
2016-02-06 21:37 EST, jamie
no flags Details
File: proc_pid_status (1.05 KB, text/plain)
2016-02-06 21:37 EST, jamie
no flags Details
File: var_log_messages (304 bytes, text/plain)
2016-02-06 21:37 EST, jamie
no flags Details

  None (edit)
Description jamie 2016-02-06 21:37:15 EST
Description of problem:
1. Installed Espeak 
2.Type 'espeak' on the terminal 
3. Enter a few lines of text 
4. It crashes with 'espeak: wave_pulse.cpp:691: size_t wave_write(void*, char*, size_t): Assertion `stream' failed.'

Note:
I do not have PalseAudio installed, is it a depdency. 

Version-Release number of selected component:
espeak-1.48.04-6.fc23

Additional info:
reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        espeak
crash_function: wave_write
executable:     /usr/bin/espeak
global_pid:     27171
kernel:         4.3.4-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (7 frames)
 #4 wave_write at wave_pulse.cpp:691
 #5 dispatch_audio at speak_lib.cpp:136
 #6 create_events at speak_lib.cpp:214
 #7 Synthesize at speak_lib.cpp:502
 #8 sync_espeak_Synth at speak_lib.cpp:656
 #9 process_espeak_command at espeak_command.cpp:547
 #10 say_thread at fifo.cpp:452

Potential duplicate: bug 904302
Comment 1 jamie 2016-02-06 21:37:18 EST
Created attachment 1121819 [details]
File: backtrace
Comment 2 jamie 2016-02-06 21:37:19 EST
Created attachment 1121820 [details]
File: cgroup
Comment 3 jamie 2016-02-06 21:37:20 EST
Created attachment 1121821 [details]
File: core_backtrace
Comment 4 jamie 2016-02-06 21:37:21 EST
Created attachment 1121822 [details]
File: dso_list
Comment 5 jamie 2016-02-06 21:37:22 EST
Created attachment 1121823 [details]
File: environ
Comment 6 jamie 2016-02-06 21:37:23 EST
Created attachment 1121824 [details]
File: limits
Comment 7 jamie 2016-02-06 21:37:24 EST
Created attachment 1121825 [details]
File: maps
Comment 8 jamie 2016-02-06 21:37:25 EST
Created attachment 1121826 [details]
File: mountinfo
Comment 9 jamie 2016-02-06 21:37:26 EST
Created attachment 1121827 [details]
File: namespaces
Comment 10 jamie 2016-02-06 21:37:26 EST
Created attachment 1121828 [details]
File: open_fds
Comment 11 jamie 2016-02-06 21:37:27 EST
Created attachment 1121829 [details]
File: proc_pid_status
Comment 12 jamie 2016-02-06 21:37:28 EST
Created attachment 1121830 [details]
File: var_log_messages
Comment 13 Jaroslav Škarvada 2016-02-08 04:52:26 EST
Sorry it doesn't work without PulseAudio. For details see bug 799137. If you need to run it without PulseAudio you need to rebuild it yourself by 'rpmbuild --with portaudio'.

It has PulseAudio in implicit dependency:
libpulse.so.0()(64bit)
libpulse.so.0(PULSE_0)(64bit)

I am ready to return the support for portaudio once upstream refactorize the code to be able to use modules / subpackages.
Comment 14 jamie 2016-02-08 19:06:27 EST
Thanks for letting me know what the issue is.

Note You need to log in before you can comment on or make changes to this bug.