Bug 1305319 - ICE while building polymake
ICE while building polymake
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-06 23:56 EST by Jerry James
Modified: 2016-02-19 17:27 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-19 17:27:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Compressed preprocessed file (309.41 KB, application/x-xz)
2016-02-06 23:56 EST, Jerry James
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 69241 None None None 2016-02-08 05:38 EST

  None (edit)
Description Jerry James 2016-02-06 23:56:48 EST
Created attachment 1121831 [details]
Compressed preprocessed file

Description of problem:
The polymake package failed the mass rebuild.  Inspecting the build log revealed that polymake is not ready for C++14 yet, so I added -std=gnu++98 to the build flags and tried a mock build.  GCC stopped with an internal compiler error.

Version-Release number of selected component (if applicable):
gcc-6.0.0-0.9.fc24.x86_64

How reproducible:
Only tried once.

Steps to Reproduce:
1. Compile the attached preprocessed file
2.
3.

Actual results:
Internal compiler error.

Expected results:
Successful compilation.

Additional info:
Comment 1 Jakub Jelinek 2016-02-08 08:26:17 EST
That PR should be fixed in gcc-6.0.0-0.10.fc24.
Comment 2 Jerry James 2016-02-19 17:27:11 EST
It is fixed.  Thank you!

Note You need to log in before you can comment on or make changes to this bug.