Bug 1305328 - [abrt] dnf: output.py:2181:_out_progress:OSError: [Errno 5] Input/output error [NEEDINFO]
[abrt] dnf: output.py:2181:_out_progress:OSError: [Errno 5] Input/output error
Status: CLOSED DUPLICATE of bug 1293761
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:a807bc24bea7a12fc505fff528a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-07 02:57 EST by Chen_Min_Chin
Modified: 2016-03-19 13:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-08 08:05:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jsilhan: needinfo? (tcfxfzoi)


Attachments (Terms of Use)
File: _var_log_dnf.log (326.69 KB, text/plain)
2016-02-07 02:57 EST, Chen_Min_Chin
no flags Details
File: backtrace (992 bytes, text/plain)
2016-02-07 02:57 EST, Chen_Min_Chin
no flags Details
File: dnf-makecache.log (1.21 MB, text/plain)
2016-02-07 02:57 EST, Chen_Min_Chin
no flags Details
File: environ (2.83 KB, text/plain)
2016-02-07 02:57 EST, Chen_Min_Chin
no flags Details

  None (edit)
Description Chen_Min_Chin 2016-02-07 02:57:05 EST
Version-Release number of selected component:
dnf-1.1.6-1.fc23

Additional info:
reporter:       libreport-2.6.4
cmdline:        /usr/bin/python3 /usr/bin/dnf -y update
executable:     /usr/bin/dnf
kernel:         4.3.4-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
output.py:2181:_out_progress:OSError: [Errno 5] Input/output error

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/dnf/yum/rpmtrans.py", line 415, in callback
    self._instProgress( bytes, total, h )
  File "/usr/lib/python3.4/site-packages/dnf/yum/rpmtrans.py", line 493, in _instProgress
    self.total_actions)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 2157, in progress
    percent, process, pkgname, wid1)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 2181, in _out_progress
    sys.stdout.flush()
OSError: [Errno 5] Input/output error

Local variables in innermost frame:
fmt: '  %s: %s     1/106'
wid2: 59
wid1: 6
self: <dnf.cli.output.CliTransactionDisplay object at 0x7f16b93da550>
process: '升級中'
percent: 100
pkgname: 'systemd-libs-222-14.fc23.x86_64'
ts_done: 1
ti_done: 1599844
ts_total: 106
ti_total: 1599844
msg: '  升級中: systemd-libs-222-14.fc23.x86_64                                 1/106'
Comment 1 Chen_Min_Chin 2016-02-07 02:57:13 EST
Created attachment 1121858 [details]
File: _var_log_dnf.log
Comment 2 Chen_Min_Chin 2016-02-07 02:57:15 EST
Created attachment 1121859 [details]
File: backtrace
Comment 3 Chen_Min_Chin 2016-02-07 02:57:25 EST
Created attachment 1121860 [details]
File: dnf-makecache.log
Comment 4 Chen_Min_Chin 2016-02-07 02:57:26 EST
Created attachment 1121861 [details]
File: environ
Comment 5 Honza Silhan 2016-02-08 08:05:20 EST
Can you please share how this happened? Do you have low space on disk? you don;t have tty? or do you remember anything unusual? Please aswer in original bug report. Thanks

*** This bug has been marked as a duplicate of bug 1293761 ***

Note You need to log in before you can comment on or make changes to this bug.