Bug 1305403 - [DOCS] [3.2] Document Router Sharding
[DOCS] [3.2] Document Router Sharding
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Vikram Goyal
zhaozhanqi
Vikram Goyal
:
: 1339218 (view as bug list)
Depends On:
Blocks: 1257963
  Show dependency treegraph
 
Reported: 2016-02-07 21:07 EST by Vikram Goyal
Modified: 2016-08-06 19:57 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-31 15:36:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikram Goyal 2016-02-07 21:07:52 EST
Routers (since 3.1.1) support overriding the host value in a route at startup. You can start multiple routers and serve the same route over different wildcards (with different configurations). See the help text for openshift-router.

https://docs.openshift.com/enterprise/3.1/release_notes/ose_3_1_release_notes.html#ose-3-1-1

However, this information on how to setup the routes is not specified in the docs and should be documented for 3.2.

See this thread for more info and background:
http://lists.openshift.redhat.com/openshift-archives/dev/2016-January/msg00081.html

Source from upstream docs:
https://github.com/openshift/origin/blob/master/docs/router_sharding.md

Relevant BZ:
https://bugzilla.redhat.com/show_bug.cgi?id=1257963

No Trello cards AFAIK.

Dev for contact:
Clayton Coleman

QA for contact:
Zhanqi Zhao
Comment 2 Thien-Thi Nguyen 2016-03-14 09:20:25 EDT
Plan: Adapt the upstream docs.
Comment 6 Thien-Thi Nguyen 2016-03-24 18:34:07 EDT
There are two parts to this BZ.  First is the ability to override the host value in a route at startup.  Second is router sharding, proper.
Comment 7 Thien-Thi Nguyen 2016-03-27 17:41:12 EDT
PR for the first part (hostname override):
https://github.com/openshift/openshift-docs/pull/1815
Comment 9 Thien-Thi Nguyen 2016-04-05 09:38:31 EDT
WIP for second part:
https://github.com/tnguyen-rh/openshift-docs/tree/bz1305403-router-sharding
Comment 10 openshift-github-bot 2016-04-06 11:53:47 EDT
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/02c6f5d348f5d1070bd2652cb115954d3dfe5355
Merge pull request #1815 from tnguyen-rh/bz1305403

Bug 1305403 (part 1) Describe env vars that can be used to override route hostname
Comment 12 Thien-Thi Nguyen 2016-04-07 22:12:12 EDT
PR for second part (describe router sharding):
https://github.com/openshift/openshift-docs/pull/1876
Comment 23 openshift-github-bot 2016-05-16 14:08:47 EDT
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/2bb1ed159a1d08f2161cedd98ab8005a34894d2f
Merge pull request #1876 from tnguyen-rh/bz1305403-router-sharding

Bug 1305403 - Describe router sharding
Comment 25 zhaozhanqi 2016-05-17 01:58:33 EDT
looks good to me.

verified this bug.
Comment 27 Vikram Goyal 2016-05-24 08:17:13 EDT
*** Bug 1339218 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.