Bug 130543 - rdtsc opcode invalid on some cpu (trivial fix)
rdtsc opcode invalid on some cpu (trivial fix)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-21 10:27 EDT by Eric Thomas
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-21 10:50:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Thomas 2004-08-21 10:27:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I know that support for 486 cpus is dropped but the fix is so trivial
that It would be a shame to do nothing.
Some rpm binaries cannot work on those cpus because of the use of the
rdtsc opcode.
As the opcode is specific to intel, it is already enclosed by a #if
defined(__386__) in rpmio/rpmsw.c
Replacing it by (or adding) a __686__ test could *at least* allow a
rebuild of the package without having to edit the source file first.

If any cpu-type identification could be done at runtime to allow, or
not, to use the rdtsc opcode, then it would be really great !

The bug is opened for fc3test1 because it would be nice to fix it
before fc3 release but the bug last from fc2 at least.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rebuild of the rpm package for 486 needs source file modification
first, whereas it could avoided if fixed
2.
3.
    

Additional info:
Comment 1 Jeff Johnson 2004-08-21 10:50:10 EDT
rdtsc is used to eliminate endless gettimeofday calls
in strace logs.

Sure the "fix" to use rpm on i486 is trivial. A run time
test is possible as well.

However, the vast majority of rpm users are not "i486".
Edit the source file if you need rpm on i486.
Comment 2 Eric Thomas 2004-08-21 17:54:24 EDT
Replacing __i386__ by __586__ would have cost you less time than
answering me why you won't do it :-(
And no one from "the vast majority" would have suffered from it.

Note You need to log in before you can comment on or make changes to this bug.