Bug 1305482 - JAVA path expansion
JAVA path expansion
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-sdk-java (Show other bugs)
3.6.0
All All
unspecified Severity medium
: ovirt-3.6.3
: ---
Assigned To: Juan Hernández
Pavol Brilla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 06:46 EST by Pavol Brilla
Modified: 2016-02-17 02:33 EST (History)
8 users (show)

See Also:
Fixed In Version: rhevm-sdk-java-3.6.2.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1305871 (view as bug list)
Environment:
Last Closed: 2016-02-17 02:33:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavol Brilla 2016-02-08 06:46:47 EST
Description of problem:

During erratum run I received:
/usr/src/redhat/BUILD/ovirt-engine-sdk-java-3.6.2.0/generator/regenerate.xml:22: Execute failed: java.io.IOException: Cannot run program "xjc": error=2, No such file or directory


Version-Release number of selected component (if applicable):
rhevm-sdk-java-3.6.2.0-1.el6ev.src.rpm

How reproducible:
100%

Steps to Reproduce:
1.  run ET for rhevm-sdk-java

Actual results:


Expected results:
xjc should be found
Comment 1 Juan Hernández 2016-02-08 06:50:24 EST
This happens because we assume that the directory /usr/lib/jvm/java-1.8.0-openjdk always exists. But that isn't true, because this is created by the "alternatives" tool, and may not exist in some situations. To avoid this issue we can instead calculate JAVA_HOME like this:

JAVA_HOME=$(dirname $(rpm -ql java-1.8.0-openjdk-devel | grep '/bin$'))
Comment 2 Juan Hernández 2016-02-08 06:51:56 EST
Pavol, do we need this fixed in order to pass TPS tests, or is there any workaround?
Comment 3 Pavol Brilla 2016-02-09 07:52:08 EST
Juan, should be fixed, TPS is here to check that we don't need any workarounds
Comment 5 Oved Ourfali 2016-02-11 08:34:59 EST
Juan - should this be on_qa?
Comment 6 Juan Hernández 2016-02-11 08:40:30 EST
Yes, it should.
Comment 7 Gil Klein 2016-02-17 02:33:05 EST
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.