Bug 1305483 - Parameter 'Compute-1::KeyName' is invalid: Error validating value u'default': The Key (default) could not be found.
Parameter 'Compute-1::KeyName' is invalid: Error validating value u'default':...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHELOSP (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: John Matthews
Landon LaSmith
Dan Macpherson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 06:47 EST by Antonin Pagac
Modified: 2016-09-13 12:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:26:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
relevant part from production.log (18.19 KB, text/plain)
2016-02-08 06:47 EST, Antonin Pagac
no flags Details

  None (edit)
Description Antonin Pagac 2016-02-08 06:47:18 EST
Created attachment 1122149 [details]
relevant part from production.log

Description of problem:
When running a deployment of RHELOSP+CFME, the Openstack installation fails at 27.8% with an error message:

 Expected(201) <=> Actual(400 Bad Request) response => #<Excon::Response:0x0000001011bdd0 @data={:body=>"{\"explanation\": \"The server could not comply with the request since it is either malformed or otherwise incorrect.\", \"code\": 400, \"error\": {\"message\": \"Parameter 'Compute-1::KeyName' is invalid: Error validating value u'default': The Key (default) could not be found.\", \"traceback\": \"Traceback (most recent call last):\\n\\n File \\\"/usr/lib/python2.7/site-packages/heat/common/context.py\\\", line 300, in wrapped\\n return func(self, ctx, *args, **kwargs)\\n\\n File \\\"/usr/lib/python2.7/site-packages/heat/engine/service.py\\\", line 670, in create_stack\\n parent_resource_name)\\n\\n File \\\"/usr/lib/python2.7/site-packages/heat/engine/service.py\\\", line 578, in _parse_template_and_validate_stack\\n stack.validate()\\n\\n File \\\"/usr/lib/python2.7/site-packages/osprofiler/profiler.py\\\", line 105, in wrapper\\n return f(*args, **kwargs)\\n\\n File \\\"/usr/lib/python2.7/site-packages/heat/engine/stack.py\\\", line 574, in validate\\n validate_value=self.strict_validate)\\n\\n File \\\"/usr/lib/python2.7/site-packages/heat/engine/parameters.py\\\", line 495, in validate\\n param.validate(validate_value, context)\\n\\n File \\\"/usr/lib/python2.7/site-packages/heat/engine/parameters.py\\\", line 236, in validate\\n raise exception.StackValidationFailed(message=msg)\\n\\nStackValidationFailed: Parameter 'Compute-1::KeyName' is invalid: Error validating value u'default': The Key (default) could not be found.\\n\", \"type\": \"StackValidationFailed\"}, \"title\": \"Bad Request\"}", :headers=>{"Content-Type"=>"application/json; charset=UTF-8", "Content-Length"=>"1473", "X-Openstack-Request-Id"=>"req-bc98f4c5-bb32-4f3f-848d-4e372fa65e24", "Date"=>"Mon, 08 Feb 2016 11:03:09 GMT"}, :status=>400, :remote_ip=>"192.0.2.1", :local_port=>53880, :local_address=>"192.168.252.1"}, @body="{\"explanation\": \"The server could not comply with the request since it is either malformed or otherwise incorrect.\", \"code\": 400, \"error\": {\"message\": \"Parameter 'Compute-1::KeyName' is invalid: Error validating value u'default': The Key (default) could not be found.\", \"traceback\": \"Traceback (most recent call last):\\n\\n File \\\"/usr/lib/python2.7/site-packages/heat/common/context.py\\\", line 300, in wrapped\\n return func(self, ctx, *args, **kwargs)\\n\\n File \\\"/usr/lib/python2.7/site-packages/heat/engine/service.py\\\", line 670, in create_stack\\n parent_resource_name)\\n\\n File \\\"/usr/lib/python2.7/site-packages/heat/engine/service.py\\\", line 578, in _parse_template_and_validate_stack\\n stack.validate()\\n\\n File \\\"/usr/lib/python2.7/site-packages/osprofiler/profiler.py\\\", line 105, in wrapper\\n return f(*args, **kwargs)\\n\\n File \\\"/usr/lib/python2.7/site-packages/heat/engine/stack.py\\\", line 574, in validate\\n validate_value=self.strict_validate)\\n\\n File \\\"/usr/lib/python2.7/site-packages/heat/engine/parameters.py\\\", line 495, in validate\\n param.validate(validate_value, context)\\n\\n File \\\"/usr/lib/python2.7/site-packages/heat/engine/parameters.py\\\", line 236, in validate\\n raise exception.StackValidationFailed(message=msg)\\n\\nStackValidationFailed: Parameter 'Compute-1::KeyName' is invalid: Error validating value u'default': The Key (default) could not be found.\\n\", \"type\": \"StackValidationFailed\"}, \"title\": \"Bad Request\"}", @headers={"Content-Type"=>"application/json; charset=UTF-8", "Content-Length"=>"1473", "X-Openstack-Request-Id"=>"req-bc98f4c5-bb32-4f3f-848d-4e372fa65e24", "Date"=>"Mon, 08 Feb 2016 11:03:09 GMT"}, @status=400, @remote_ip="192.0.2.1", @local_port=53880, @local_address="192.168.252.1"> 

For this deployment, I'm using 'old' satellite with synced content and removed old Director, and a newly installed Director. I've removed the ssh key for the old Director previously associated with this Satellite from '/usr/share/foreman/.ssh/known_hosts' and I have removed entries related to Openstack from '/etc/named/dynamic/db.rhci.com' by doing:

rndc freeze, vim /etc/named/dynamic/db.rhci.com, increment serial, remove the osp entries, save, rndc reload, rhdc thaw

All this was done so I could use the same network configuration as with the previous Director. Director discovery and node introspection went without problems.

Version-Release number of selected component (if applicable):
RHCI-6.0-RHEL-7-20160205.1-RHCI-x86_64-dvd1.iso
RHCIOOO-7-RHEL-7-20160127.0-RHCIOOO-x86_64-dvd1.iso

How reproducible:
Happened to me once

Steps to Reproduce:
1. Have working deployment of RHELOSP
2. Remove the Director from the Satellite using above described steps
3. Reinstall Director, run fusor-undercloud-installer on it, configure it
4. Start new deployment of RHELOSP using the reinstalled Director
5. Error appears at 27.8% after successful content sync

Actual results:
RHELOSP deployment failed; error displayed on Installation Progress page

Expected results:
RHELOSP deployment successful

Additional info:
See relevant part of production.log
Comment 1 Antonin Pagac 2016-02-08 08:48:01 EST
Correction: the file for named configuration is /var/named/dynamic/db.rhci.com, not /etc/..
Comment 2 John Matthews 2016-06-14 15:55:42 EDT
Please re-test with OSP8
Comment 7 Landon LaSmith 2016-09-12 00:51:24 EDT
VERIFIED. After using fusor for multiple OSP deployments, I was able to reinstall the director from iso and deploy RHEV+OSP+CFME successfully using the same OSP controller/compute nodes for deployment. I didn't modify the entries for the previous OSP install in named.

QCI Media Version: QCI-1.0-RHEL-7-20160908.1
QCIOOO Media Version: QCIOOO-8.0-RHEL-7-20160907.2
Comment 9 errata-xmlrpc 2016-09-13 12:26:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.