Bug 1305488 - nfsidmap: Failed to add child keyring: Operation not permitted [NEEDINFO]
nfsidmap: Failed to add child keyring: Operation not permitted
Status: CLOSED DUPLICATE of bug 1303877
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steve Dickson
Filesystem QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 07:09 EST by michal novacek
Modified: 2016-12-21 20:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-13 08:56:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ckloiber: needinfo?


Attachments (Terms of Use)
'pcs cluster report' output (417.46 KB, application/x-bzip)
2016-02-08 07:09 EST, michal novacek
no flags Details

  None (edit)
Description michal novacek 2016-02-08 07:09:05 EST
Created attachment 1122150 [details]
'pcs cluster report' output

Description of problem:
I'm recently getting 'nfsidmap[4540]: Failed to add child keyring: Operation
not permitted' with NFS cluster HA testing. I found out this problem while
testing nfs (re-)locking of file while nfs server is moving from node to node.

Version-Release number of selected component (if applicable):
nfs-utils-1.2.3-68.el6.x86_64
kernel-2.6.32-613.el6.x86_64

How reproducible: always

Steps to Reproduce:
1. have running pacemaker ha nfs server
2. on the client node outside of cluster mount nfs from server and exclusively
    lock file
3. move nfs server to another node

Actual results: long time to determine lock acquisition/denial + failed to add...

Expected results: short time to acquire/deny

Additional info:
It seems that acquiring/denying lock takes up to 10s where it previously was
less than 1s (RHEL-6.8-20160205.n.0 snapshot).
Comment 2 Steve Dickson 2016-02-13 08:56:07 EST

*** This bug has been marked as a duplicate of bug 1303877 ***
Comment 3 Chris Kloiber 2016-11-28 11:19:18 EST
bug 1303877 is marked as PRIVATE. Please update this public bug, or permit access to the listed bug.

Note You need to log in before you can comment on or make changes to this bug.