Bug 1305491 - oidentd lacks masquerade support
oidentd lacks masquerade support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: oidentd (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 07:23 EST by Konstantin Zemlyak
Modified: 2016-02-21 11:28 EST (History)
3 users (show)

See Also:
Fixed In Version: oidentd-2.0.8-18.fc23 oidentd-2.0.8-16.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-20 21:23:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konstantin Zemlyak 2016-02-08 07:23:56 EST
Since some time oidentd package in Fedora lacks masquerade support.

When trying to build the package by hand I got in config.log:

configure:8437: checking for /usr/src/sys/contrib/ipfilter/netinet/ip_nat.h
configure:8444: result: no
configure:8751: WARNING: not including NAT/IP masquerade support.

The code should be updated to use NetFilter instead.
Comment 1 Petr Pisar 2016-02-09 04:11:02 EST
Could you please tell me what oidentd package version do you use and when did the masquerading work for you last time?
Comment 2 Petr Pisar 2016-02-09 06:24:29 EST
The message appears in:

oidentd-2.0.8-17.fc23
oidentd-2.0.8-15.fc22

It does not appear in:

oidentd-2.0.8-19.fc24

That's because I modernized and corrected the package only in F24. I will merge the changes into older Fedoras. Please test package when the updated build becomes available in the testing repository.
Comment 3 Fedora Update System 2016-02-09 07:00:36 EST
oidentd-2.0.8-18.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fa9a7cd0e0
Comment 4 Fedora Update System 2016-02-09 07:00:55 EST
oidentd-2.0.8-16.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f7f05bcd7f
Comment 5 Fedora Update System 2016-02-10 13:23:40 EST
oidentd-2.0.8-16.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f7f05bcd7f
Comment 6 Fedora Update System 2016-02-10 13:51:50 EST
oidentd-2.0.8-18.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fa9a7cd0e0
Comment 7 Fedora Update System 2016-02-20 21:23:32 EST
oidentd-2.0.8-16.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2016-02-21 11:28:23 EST
oidentd-2.0.8-18.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.