Bug 1305561 - Windows 7 doesn't adjust resolution for second remote-viewer's display.
Windows 7 doesn't adjust resolution for second remote-viewer's display.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-vdagent-win (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Default Assignee for SPICE Bugs
SPICE QE bug list
: Regression
Depends On:
Blocks: 1174129
  Show dependency treegraph
 
Reported: 2016-02-08 10:07 EST by Andrei Stepanov
Modified: 2016-03-30 06:54 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 06:54:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
remote-viewer screenshot (482.44 KB, image/png)
2016-02-08 10:16 EST, Andrei Stepanov
no flags Details
remote-viewer log (resizing window action) (132.60 KB, text/plain)
2016-02-08 11:26 EST, Andrei Stepanov
no flags Details

  None (edit)
Description Andrei Stepanov 2016-02-08 10:07:57 EST
Windows 7 64 doesn't update resolution on second monitor.

Guest is: Win7 + RHEV-toolsSetup_3.6_4.iso
Client is: virt-viewer-2.0-6.el7.x86_64
Host is: vdsm-4.17.19-0.el7ev.noarch + spice-server-0.12.4-15.el7.x86_64

How reproducible: always.

Steps to Reproduce:
1. Connect to guest os.
2. Activate in remote-viewer two displays.
3. Try to resize remote-viewer's window with secondary display.

Actual results:
Resolution on second displays is updated in wrong way.
Windows7 reports a new resolution on second display. Active canvas doesn't fill all remote-viewer's window. See screenshots.
Comment 1 Andrei Stepanov 2016-02-08 10:16 EST
Created attachment 1122186 [details]
remote-viewer screenshot
Comment 2 Andrei Stepanov 2016-02-08 11:26 EST
Created attachment 1122195 [details]
remote-viewer log (resizing window action)
Comment 3 Jonathon Jongsma 2016-03-17 16:05:41 EDT
You listed this as a regression. Can you identify which versions work and which version the regression is introduced on?
Comment 4 Andrei Stepanov 2016-03-30 06:54:07 EDT
I cannot reproduce this bug with RHEV-toolsSetup_3.6_5.iso from rhev-guest-tools-iso-3.6-5.el6ev.noarch

Note You need to log in before you can comment on or make changes to this bug.