Bug 1305571 - mount.nfs provokes "INFO: suspicious RCU usage."
mount.nfs provokes "INFO: suspicious RCU usage."
Status: CLOSED DUPLICATE of bug 1281447
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: nfs-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 10:38 EST by Richard W.M. Jones
Modified: 2016-12-19 17:16 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-19 17:16:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full dmesg output (80.10 KB, text/plain)
2016-02-08 10:38 EST, Richard W.M. Jones
no flags Details

  None (edit)
Description Richard W.M. Jones 2016-02-08 10:38:45 EST
Created attachment 1122187 [details]
Full dmesg output

Description of problem:

This is bad, isn't it?

The init script just mounts a few NFSv4 mounts.

The full dmesg is attached.  Excerpt is:

[   20.704492] ===============================
[   20.708837] [ INFO: suspicious RCU usage. ]
[   20.713196] 4.5.0-0.rc1.git2.1.fc24.x86_64 #1 Tainted: G          I    
[   20.719967] -------------------------------
[   20.724314] include/keys/user-type.h:53 suspicious rcu_dereference_protected() usage!
[   20.732288] 
               other info that might help us debug this:

[   20.740909] 
               rcu_scheduler_active = 1, debug_locks = 0
[   20.747761] 1 lock held by mount.nfs/1897:
[   20.752014]  #0:  (rcu_read_lock){......}, at: [<ffffffffa089d9f5>] nfs_idmap_get_key+0xe5/0x2f0 [nfsv4]
[   20.761724] 
               stack backtrace:
[   20.766422] CPU: 7 PID: 1897 Comm: mount.nfs Tainted: G          I     4.5.0-0.rc1.git2.1.fc24.x86_64 #1
[   20.776057] Hardware name: Dell Inc. Precision WorkStation T5500  /0D883F, BIOS A12 12/29/2011
[   20.784825]  0000000000000000 000000001576f158 ffff880fbb4a74c0 ffffffff8144d37a
[   20.792435]  ffff880fbb443100 ffff880fbb4a74f0 ffffffff8110aa87 ffff880fd16aa080
[   20.800052]  0000000000000000 ffff880fd16aa080 0000000000000015 ffff880fbb4a7558
[   20.807672] Call Trace:
[   20.810299]  [<ffffffff8144d37a>] dump_stack+0x4b/0x71
[   20.815613]  [<ffffffff8110aa87>] lockdep_rcu_suspicious+0xd7/0x110
[   20.822062]  [<ffffffffa089da87>] nfs_idmap_get_key+0x177/0x2f0 [nfsv4]
[   20.828860]  [<ffffffffa089d9f5>] ? nfs_idmap_get_key+0xe5/0x2f0 [nfsv4]
[   20.835745]  [<ffffffffa089e305>] nfs_map_name_to_uid+0x165/0x200 [nfsv4]
[   20.842706]  [<ffffffff81026b39>] ? sched_clock+0x9/0x10
[   20.848208]  [<ffffffffa08933c2>] decode_getfattr_attrs+0x11e2/0x1730 [nfsv4]
[   20.855527]  [<ffffffffa08939ab>] decode_getfattr_generic.constprop.103+0x9b/0x100 [nfsv4]
[   20.863970]  [<ffffffffa08949d0>] ? nfs4_xdr_dec_clone+0xf0/0xf0 [nfsv4]
[   20.870853]  [<ffffffffa0894a6e>] nfs4_xdr_dec_lookup_root+0x9e/0xb0 [nfsv4]
[   20.878088]  [<ffffffffa02c5f14>] rpcauth_unwrap_resp+0xa4/0xe0 [sunrpc]
[   20.884973]  [<ffffffffa08949d0>] ? nfs4_xdr_dec_clone+0xf0/0xf0 [nfsv4]
[   20.891857]  [<ffffffffa02b345e>] call_decode+0x1de/0x9b0 [sunrpc]
[   20.898221]  [<ffffffffa02b3280>] ? rcu_read_lock+0x70/0x70 [sunrpc]
[   20.904757]  [<ffffffffa02b3280>] ? rcu_read_lock+0x70/0x70 [sunrpc]
[   20.911296]  [<ffffffffa02c14cc>] __rpc_execute+0xbc/0x560 [sunrpc]
[   20.917740]  [<ffffffff811007c5>] ? wake_up_bit+0x25/0x30
[   20.923325]  [<ffffffffa02c47b5>] rpc_execute+0x85/0x140 [sunrpc]
[   20.929603]  [<ffffffffa02b6a70>] rpc_run_task+0x70/0x90 [sunrpc]
[   20.935882]  [<ffffffffa0876923>] nfs4_call_sync_sequence+0x63/0xa0 [nfsv4]
[   20.943030]  [<ffffffffa087bf2a>] _nfs4_lookup_root.isra.62+0xda/0x100 [nfsv4]
[   20.950440]  [<ffffffffa08826b8>] nfs4_lookup_root+0x98/0x1b0 [nfsv4]
[   20.957065]  [<ffffffff8112c805>] ? rcu_read_lock_sched_held+0x45/0x80
[   20.963778]  [<ffffffffa0882839>] nfs4_lookup_root_sec+0x69/0x90 [nfsv4]
[   20.970666]  [<ffffffffa0882899>] nfs4_find_root_sec+0x39/0xb0 [nfsv4]
[   20.977383]  [<ffffffffa08864ac>] nfs4_proc_get_rootfh+0x3c/0x90 [nfsv4]
[   20.984276]  [<ffffffffa08a397a>] nfs4_get_rootfh+0x5a/0x140 [nfsv4]
[   20.990813]  [<ffffffff8112c805>] ? rcu_read_lock_sched_held+0x45/0x80
[   20.997524]  [<ffffffff8125feec>] ? kmem_cache_alloc_trace+0x26c/0x2d0
[   21.004238]  [<ffffffffa07a555f>] ? nfs_alloc_fattr+0x1f/0x70 [nfs]
[   21.010698]  [<ffffffffa08a3d6f>] nfs4_server_common_setup+0x9f/0x1d0 [nfsv4]
[   21.018025]  [<ffffffffa08a5a0c>] nfs4_create_server+0x27c/0x380 [nfsv4]
[   21.024912]  [<ffffffff811099c5>] ? lockdep_init_map+0x65/0x6b0
[   21.031022]  [<ffffffffa089a1de>] nfs4_remote_mount+0x2e/0x60 [nfsv4]
[   21.037643]  [<ffffffff812938da>] mount_fs+0x3a/0x160
[   21.042875]  [<ffffffff812b4ece>] ? alloc_vfsmnt+0x19e/0x230
[   21.048718]  [<ffffffff812b546b>] vfs_kern_mount+0x6b/0x150
[   21.054485]  [<ffffffffa089a0bc>] ? nfs_do_root_mount+0x3c/0xc0 [nfsv4]
[   21.061289]  [<ffffffffa089a104>] nfs_do_root_mount+0x84/0xc0 [nfsv4]
[   21.067920]  [<ffffffffa089a4f4>] nfs4_try_mount+0x44/0xd0 [nfsv4]
[   21.074284]  [<ffffffffa079d3a7>] ? get_nfs_version+0x27/0x90 [nfs]
[   21.080733]  [<ffffffffa07ac210>] nfs_fs_mount+0x670/0xd40 [nfs]
[   21.086923]  [<ffffffffa07aca10>] ? nfs_clone_super+0x130/0x130 [nfs]
[   21.093542]  [<ffffffffa07a9e90>] ? param_set_portnr+0x70/0x70 [nfs]
[   21.100069]  [<ffffffff812938da>] mount_fs+0x3a/0x160
[   21.105294]  [<ffffffff812b4ece>] ? alloc_vfsmnt+0x19e/0x230
[   21.111116]  [<ffffffff812b546b>] vfs_kern_mount+0x6b/0x150
[   21.116855]  [<ffffffff812b83dc>] do_mount+0x24c/0xe60
[   21.122164]  [<ffffffff8125feec>] ? kmem_cache_alloc_trace+0x26c/0x2d0
[   21.128855]  [<ffffffff812b7f6c>] ? copy_mount_options+0x2c/0x230
[   21.135112]  [<ffffffff812b9303>] SyS_mount+0x83/0xd0
[   21.140333]  [<ffffffff818b6bb2>] entry_SYSCALL_64_fastpath+0x12/0x72

Version-Release number of selected component (if applicable):

nfs-utils-1.3.3-6.rc3.fc24.x86_64
kernel 4.5.0-0.rc1.git2.1.fc24.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Boot the physical machine.
Comment 1 Jason Tibbitts 2016-12-19 17:12:16 EST
This is almost certainly a dup of https://bugzilla.redhat.com/show_bug.cgi?id=1281447 but they aren't assigned to the same component.  I'm not sure who wants it.
Comment 2 Richard W.M. Jones 2016-12-19 17:16:45 EST
Looks likely.

*** This bug has been marked as a duplicate of bug 1281447 ***

Note You need to log in before you can comment on or make changes to this bug.