Bug 1305580 - httpd supplied jb-ews-2-for-rhel-6-server-rpms deplist is missing apr-util-ldap
httpd supplied jb-ews-2-for-rhel-6-server-rpms deplist is missing apr-util-ldap
Status: CLOSED ERRATA
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: httpd (Show other bugs)
2.1.0
x86_64 Linux
high Severity high
: DR02
: 2.1.1
Assigned To: George Zaronikas
fgoldefu
:
Depends On:
Blocks: 1338656
  Show dependency treegraph
 
Reported: 2016-02-08 10:50 EST by Dave Sullivan
Modified: 2016-09-16 10:04 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Included a sub-package that contains the ldap dependency. apr-util-ldap is in an optional RHEL7 channel, therefore the new sub-package is added, customers using ldap authentication need to install it with the dependency.
Story Points: ---
Clone Of:
: 1338656 (view as bug list)
Environment:
Last Closed: 2016-09-15 18:00:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2586131 None None None 2016-09-16 10:04 EDT

  None (edit)
Description Dave Sullivan 2016-02-08 10:50:27 EST
Description of problem:

httpd supplied jb-ews-2-for-rhel-6-server-rpms deplist is missing apr-util-ldap

If you look a an httpd version supplied by rhel-6-server-rpms channels we see a proper dependency.



Version-Release number of selected component (if applicable):

What repos do we have access too

[root@osenode01 ~]# yum repolist
Loaded plugins: priorities, product-id, security, subscription-manager
jb-eap-6-for-rhel-6-server-rpms                                                                                                                                                             | 3.7 kB     00:00     
jb-eap-6-for-rhel-6-server-rpms/primary_db                                                                                                                                                  | 677 kB     00:00     
jb-ews-2-for-rhel-6-server-rpms                                                                                                                                                             | 3.7 kB     00:00     
jb-ews-2-for-rhel-6-server-rpms/primary_db                                                                                                                                                  | 114 kB     00:00     
rhel-6-server-ose-2.2-jbosseap-rpms                                                                                                                                                         | 3.1 kB     00:00     
rhel-6-server-ose-2.2-node-rpms                                                                                                                                                             | 3.1 kB     00:00     
rhel-6-server-rpms                                                                                                                                                                          | 3.7 kB     00:00     
rhel-6-server-rpms/primary_db                                                                                                                                                               |  36 MB     00:01     
rhel-server-rhscl-6-rpms                                                                                                                                                                    | 3.1 kB     00:00     
65 packages excluded due to repository priority protections
repo id                                                                           repo name                                                                                                              status
jb-eap-6-for-rhel-6-server-rpms                                                   JBoss Enterprise Application Platform 6 (RHEL 6 Server) (RPMs)                                                           2,664+32
jb-ews-2-for-rhel-6-server-rpms                                                   JBoss Enterprise Web Server 2 (RHEL 6 Server) (RPMs)                                                                       314+35
rhel-6-server-ose-2.2-jbosseap-rpms                                               Red Hat OpenShift Enterprise 2.2 JBoss EAP add-on (RPMs)                                                                       12
rhel-6-server-ose-2.2-node-rpms                                                   Red Hat OpenShift Enterprise 2.2 Application Node (RPMs)                                                                    479+1
rhel-6-server-rpms                                                                Red Hat Enterprise Linux 6 Server (RPMs)                                                                               16,372+138
rhel-server-rhscl-6-rpms                                                          Red Hat Software Collections RPMs for Red Hat Enterprise Linux 6 Server                                                     5,028
repolist: 24,869

Let's check httpd provided from standard rhel-6-server-rpms channel

[root@osenode01 ~]# yum --disablerepo=jb-ews-2-for-rhel-6-server-rpms deplist httpd-2.2.15-47.el6_7.x86_64 | grep apr
  dependency: libaprutil-1.so.0()(64bit)
   provider: apr-util.x86_64 1.3.9-3.el6
   provider: apr-util.x86_64 1.3.9-3.el6_0.1
  dependency: libapr-1.so.0()(64bit)
   provider: apr.x86_64 1.3.9-3.el6
   provider: apr.x86_64 1.3.9-3.el6_0.1
   provider: apr.x86_64 1.3.9-3.el6_1.2
   provider: apr.x86_64 1.3.9-5.el6_2
  dependency: apr-util-ldap
   provider: apr-util-ldap.x86_64 1.3.9-3.el6
   provider: apr-util-ldap.x86_64 1.3.9-3.el6_0.1

So as seen above the dependency is correct.

Now let's look at the httpd deplist for a jb-ews channel

[root@osenode01 ~]# yum --disableexcludes=all --disablerepo=rhel-6-server-rpms deplist httpd-2.2.26-39.ep6.el6.x86_64 | grep apr
  dependency: libaprutil-1.so.0()(64bit)
  dependency: libapr-1.so.0()(64bit)


Expected results:

The httpd provided from jb-ews channel should have the same deplist relative to apr-util-ldap


Additional info:
Comment 3 Permaine Cheung 2016-05-26 14:05:38 EDT
Weinan, please fix that in the httpd build. Thanks!
Comment 14 errata-xmlrpc 2016-09-15 18:00:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1903.html

Note You need to log in before you can comment on or make changes to this bug.