Bug 130563 - Hal not creating fstab entry for my usbstick
Summary: Hal not creating fstab entry for my usbstick
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: hal   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-21 22:19 UTC by Jef Spaleta
Modified: 2013-03-13 04:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-21 22:50:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of hald debug mode (3.37 KB, text/plain)
2004-08-21 22:24 UTC, Jef Spaleta
no flags Details

Description Jef Spaleta 2004-08-21 22:19:38 UTC
Description of problem:

I plugin the usbstick and hal doesnt create an fstab entry.
I do see udev messages about creating a /dev/sdb and /dev/sdb1

Attached is the output from
/usr/sbin/hald --daemon=no 2>/tmp/hald_out.txt
showing my inserting the usbflash device
Here are the messages of interest i think:

[W] linux/osspec.c:618 handle_udev_node_created_found_device() : No
HAL device corresponding to device file /dev/sdb
[W] linux/osspec.c:618 handle_udev_node_created_found_device() : No
HAL device corresponding to device file /dev/sdb1

Version-Release number of selected component (if applicable):
Name        : hal                          
Version     : 0.2.97.cvs20040819                
Release     : 1                             
Build Date: Thu 19 Aug 2004 03:30:59 PM EDT
Install Date: Fri 20 Aug 2004 10:16:00 PM EDT      
Build Host: tweety.build.redhat.com

How reproducible:
every time

Steps to Reproduce:
1. start hal
2. plugin usb mass-storage
3. cry into your beer as you notice the fstab entry is not created. 
  
Actual results:
no fstab entry created

Expected results:
painfully painless automation of the addition and removal of a mount
point for the usb device.



-jef

Comment 1 Jef Spaleta 2004-08-21 22:24:24 UTC
Created attachment 102962 [details]
output of hald debug mode

Comment 2 Jef Spaleta 2004-08-21 22:50:35 UTC
crap!
nevermind... i just did a reinstall of the hal package... it it works
something must have gone wrong during the update to rawhide.

I'll close this as not a bug, and hang my head in shame.


-jef


Note You need to log in before you can comment on or make changes to this bug.