Bug 1305666 - ospd-8 poodle 2016-02-04.1 tempest.api.object_storage.test_container_quotas.ContainerQuotasTest.test_upload_large_object failing
ospd-8 poodle 2016-02-04.1 tempest.api.object_storage.test_container_quotas.C...
Status: CLOSED DUPLICATE of bug 1305664
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-swift (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Pete Zaitcev
nlevinki
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 15:36 EST by Steve Linabery
Modified: 2016-04-26 18:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-08 15:38:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Linabery 2016-02-08 15:36:09 EST
Description of problem:

ospd-8 poodle 2016-02-04.1 tempest.api.object_storage.test_container_quotas.ContainerQuotasTest.test_upload_large_object failing

Stacktrace

Traceback (most recent call last):
testtools.testresult.real._StringException: Empty attachments:
  stderr
  stdout

pythonlogging:'': {{{
2016-02-08 12:34:34,883 26235 INFO     [tempest_lib.common.rest_client] Request (ContainerQuotasTest:setUp): 200 POST http://172.16.23.110:5000/v2.0/tokens
2016-02-08 12:34:34,883 26235 DEBUG    [tempest_lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json'}
        Body: <omitted>
    Response - Headers: {'status': '200', 'content-length': '4291', 'vary': 'X-Auth-Token', 'connection': 'close', 'date': 'Mon, 08 Feb 2016 17:34:34 GMT', 'content-type': 'application/json', 'x-openstack-request-id': 'req-435eddc8-c19c-420d-9c6c-e3b5541f34a2'}
        Body: {"access": {"token": {"issued_at": "2016-02-08T17:34:34.517678", "expires": "2016-02-08T18:34:34Z", "id": "225e449e5a3f418e82b4b2624c364c6a", "tenant": {"description": "tempest-ContainerQuotasTest-1630227714-desc", "enabled": true, "id": "55194291d9344cba8ad1c3d664a80725", "name": "tempest-ContainerQuotasTest-1630227714"}, "audit_ids": ["_fS0jm0qRxKg7_lbsZcRug"]}, "serviceCatalog": [{"endpoints": [{"adminURL": "http://172.16.20.11:8774/v2/55194291d9344cba8ad1c3d664a80725", "region": "regionOne", "internalURL": "http://172.16.20.11:8774/v2/55194291d9344cba8ad1c3d664a80725", "id": "00325bd4385241b8b9a192cb3e6464ef", "publicURL": "http://172.16.23.110:8774/v2/55194291d9344cba8ad1c3d664a80725"}], "endpoints_links": [], "type": "compute", "name": "nova"}, {"endpoints": [{"adminURL": "http://172.16.20.11:9696/", "region": "regionOne", "internalURL": "http://172.16.20.11:9696/", "id": "a37fac08e6a947c9862a6609df7ee1f0", "publicURL": "http://172.16.23.110:9696/"}], "endpoints_links": [], "type": "network", "name": "neutron"}, {"endpoints": [{"adminURL": "http://172.16.20.11:8776/v2/55194291d9344cba8ad1c3d664a80725", "region": "regionOne", "internalURL": "http://172.16.20.11:8776/v2/55194291d9344cba8ad1c3d664a80725", "id": "1bde94b07e8f47e6b4f94b82e51e5929", "publicURL": "http://172.16.23.110:8776/v2/55194291d9344cba8ad1c3d664a80725"}], "endpoints_links": [], "type": "volumev2", "name": "cinderv2"}, {"endpoints": [{"adminURL": "http://172.16.20.11:8774/v3", "region": "regionOne", "internalURL": "http://172.16.20.11:8774/v3", "id": "0eb6a4b920f949a187f7d2e7f49c586f", "publicURL": "http://172.16.23.110:8774/v3"}], "endpoints_links": [], "type": "computev3", "name": "nova"}, {"endpoints": [{"adminURL": "http://172.16.21.10:9292/", "region": "regionOne", "internalURL": "http://172.16.21.10:9292/", "id": "4c7bad1741aa45d3aeb51890db84f8d7", "publicURL": "http://172.16.23.110:9292/"}], "endpoints_links": [], "type": "image", "name": "glance"}, {"endpoints": [{"adminURL": "http://172.16.20.11:8777/", "region": "regionOne", "internalURL": "http://172.16.20.11:8777/", "id": "67c5761a1fd9433a8d1a02a607f23c0c", "publicURL": "http://172.16.23.110:8777/"}], "endpoints_links": [], "type": "metering", "name": "ceilometer"}, {"endpoints": [{"adminURL": "http://172.16.20.11:8776/v1/55194291d9344cba8ad1c3d664a80725", "region": "regionOne", "internalURL": "http://172.16.20.11:8776/v1/55194291d9344cba8ad1c3d664a80725", "id": "8b4df1be5b98406cbb9b5f6f16f785c1", "publicURL": "http://172.16.23.110:8776/v1/55194291d9344cba8ad1c3d664a80725"}], "endpoints_links": [], "type": "volume", "name": "cinder"}, {"endpoints": [{"adminURL": "http://172.16.23.110:80/dashboard/admin", "region": "regionOne", "internalURL": "http://172.16.23.110:80/dashboard/", "id": "d18b764df6ce481480125ec40aa311b6", "publicURL": "http://172.16.23.110:80/dashboard/"}], "endpoints_links": [], "type": "dashboard", "name": "horizon"}, {"endpoints": [{"adminURL": "http://172.16.20.11:8004/v1/55194291d9344cba8ad1c3d664a80725", "region": "regionOne", "internalURL": "http://172.16.20.11:8004/v1/55194291d9344cba8ad1c3d664a80725", "id": "392043e9e6af4925b904f8e4d720e3f9", "publicURL": "http://172.16.23.110:8004/v1/55194291d9344cba8ad1c3d664a80725"}], "endpoints_links": [], "type": "orchestration", "name": "heat"}, {"endpoints": [{"adminURL": "http://172.16.21.10:8080/v1", "region": "regionOne", "internalURL": "http://172.16.21.10:8080/v1/AUTH_55194291d9344cba8ad1c3d664a80725", "id": "9d79e37c724a42e2bc9d00dccab24962", "publicURL": "http://172.16.23.110:8080/v1/AUTH_55194291d9344cba8ad1c3d664a80725"}], "endpoints_links": [], "type": "object-store", "name": "swift"}, {"endpoints": [{"adminURL": "http://192.0.2.6:35357/v2.0", "region": "regionOne", "internalURL": "http://172.16.20.11:5000/v2.0", "id": "122c04b2f1854ce5adbd8537aeefeff4", "publicURL": "http://172.16.23.110:5000/v2.0"}], "endpoints_links": [], "type": "identity", "name": "keystone"}], "user": {"username": "tempest-ContainerQuotasTest-427317011", "roles_links": [], "id": "b0a13c465f914da0a934f4523b5d945a", "roles": [{"name": "_member
2016-02-08 12:34:35,465 26235 INFO     [tempest_lib.common.rest_client] Request (ContainerQuotasTest:setUp): 201 PUT http://172.16.23.110:8080/v1/AUTH_55194291d9344cba8ad1c3d664a80725/tempest-TestContainer-1241292596 0.581s
2016-02-08 12:34:35,465 26235 DEBUG    [tempest_lib.common.rest_client] Request - Headers: {'X-Auth-Token': '<omitted>'}
        Body: None
    Response - Headers: {'status': '201', 'content-length': '0', 'connection': 'close', 'x-trans-id': 'tx97590cc508fe4b39aecd7-0056b8d1aa', 'date': 'Mon, 08 Feb 2016 17:34:35 GMT', 'content-type': 'text/html; charset=UTF-8'}
        Body: 
2016-02-08 12:34:35,536 26235 INFO     [tempest_lib.common.rest_client] Request (ContainerQuotasTest:setUp): 204 POST http://172.16.23.110:8080/v1/AUTH_55194291d9344cba8ad1c3d664a80725/tempest-TestContainer-1241292596 0.071s
2016-02-08 12:34:35,537 26235 DEBUG    [tempest_lib.common.rest_client] Request - Headers: {'X-Container-Meta-quota-count': '3', 'X-Container-Meta-quota-bytes': '10', 'X-Auth-Token': '<omitted>'}
        Body: None
    Response - Headers: {'status': '204', 'content-length': '0', 'connection': 'close', 'x-trans-id': 'tx158727e94dd9491f80b03-0056b8d1aa', 'date': 'Mon, 08 Feb 2016 17:34:34 GMT', 'content-type': 'text/html; charset=UTF-8'}
        Body: 
2016-02-08 12:34:35,600 26235 INFO     [tempest_lib.common.rest_client] Request (ContainerQuotasTest:tearDown): 200 GET http://172.16.23.110:8080/v1/AUTH_55194291d9344cba8ad1c3d664a80725/tempest-TestContainer-1241292596?&limit=9999&format=json 0.063s
2016-02-08 12:34:35,601 26235 DEBUG    [tempest_lib.common.rest_client] Request - Headers: {'X-Auth-Token': '<omitted>'}
        Body: None
    Response - Headers: {'status': '200', 'content-length': '2', 'x-container-object-count': '0', 'x-container-bytes-used': '0', 'accept-ranges': 'bytes', 'x-storage-policy': 'Policy-0', 'x-container-meta-quota-count': '3', 'connection': 'close', 'x-timestamp': '1454952875.42388', 'x-trans-id': 'tx3ef8a1daf28848aa8521b-0056b8d1ab', 'date': 'Mon, 08 Feb 2016 17:34:35 GMT', 'content-type': 'application/json; charset=utf-8', 'x-container-meta-quota-bytes': '10', 'content-location': 'http://172.16.23.110:8080/v1/AUTH_55194291d9344cba8ad1c3d664a80725/tempest-TestContainer-1241292596?&limit=9999&format=json'}
        Body: []
2016-02-08 12:34:35,696 26235 INFO     [tempest_lib.common.rest_client] Request (ContainerQuotasTest:tearDown): 409 DELETE http://172.16.23.110:8080/v1/AUTH_55194291d9344cba8ad1c3d664a80725/tempest-TestContainer-1241292596 0.095s
2016-02-08 12:34:35,697 26235 DEBUG    [tempest_lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-Auth-Token': '<omitted>'}
        Body: None
    Response - Headers: {'status': '409', 'content-length': '95', 'connection': 'close', 'x-trans-id': 'tx0ec2a1ee30d148d78ba21-0056b8d1aa', 'date': 'Mon, 08 Feb 2016 17:34:34 GMT', 'content-type': 'text/html; charset=UTF-8'}
        Body: <html><h1>Conflict</h1><p>There was a conflict when trying to complete your request.</p></html>
}}}

Traceback (most recent call last):
  File "/home/stack/tempest/tempest/api/object_storage/test_container_quotas.py", line 51, in tearDown
    self.delete_containers([self.container_name])
  File "/home/stack/tempest/tempest/api/object_storage/base.py", line 88, in delete_containers
    container_client.delete_container(cont)
  File "/home/stack/tempest/tempest/services/object_storage/container_client.py", line 53, in delete_container
    resp, body = self.delete(url)
  File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 290, in delete
    return self.request('DELETE', url, extra_headers, headers, body)
  File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 640, in request
    resp, resp_body)
  File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 708, in _error_checker
    raise exceptions.Conflict(resp_body, resp=resp)
tempest_lib.exceptions.Conflict: An object with that identifier already exists
Details: <html><h1>Conflict</h1><p>There was a conflict when trying to complete your request.</p></html>
Comment 2 Steve Linabery 2016-02-08 15:38:40 EST

*** This bug has been marked as a duplicate of bug 1305664 ***

Note You need to log in before you can comment on or make changes to this bug.