Bug 1305667 - Console button goes to wrong VM on subnet
Console button goes to wrong VM on subnet
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 6.0 (Juno)
Assigned To: Itxaka
Ido Ovadia
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 15:39 EST by Caitlin Campbell
Modified: 2016-06-23 09:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 09:02:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caitlin Campbell 2016-02-08 15:39:41 EST
Description of problem:


When opening a Console in horizon, the console will be that of the most recently created VM.


Version-Release number of selected component (if applicable):

Juno


How reproducible:


Steps to Reproduce:
1. Have VM on network
2. Create second VM.
3. Launch console for second CM.

Actual results:

console for first VM launches


Expected results:

console for second VM launches

Additional info:
Comment 2 Matthias Runge 2016-02-09 04:14:05 EST
How are you trying to access the console? Spice, vnc? What version are you using?
Are you accessing the consile from networks topology page or from instances page?
Comment 3 Caitlin Campbell 2016-02-10 11:00:19 EST
I am trying to access the console via the horizon interface. I have not changed any settings as to how horizon brings up the interface. 

Looking threw the source of the horizon console page I see this link:
http://{{MYIP}}:6080/vnc_auto.html?token={{TOKEN}}&title={{TITLE}}

Because of this I assume it is using vnc.

I am accessing the console from the instances page. The same issue happens when I try to access the console from the network topology page.

As to what version, I am using the Juno release of Openstack. I am using various browsers to view the console and they all have the same result.

I hope this information is of assistance.
Comment 4 Matthias Runge 2016-02-23 03:09:31 EST
re-adjusting target release.
Comment 5 Itxaka 2016-04-26 08:24:42 EDT
I am unable to reproduce this.

Could we get a bit more explanation on how to reproduce this?

Where are you going to the console link from? From the instances page? From the network topology page?

Note that in both cases I could reach the proper console for the selected instance so it feels like Im missing some steps in here.

Could you try and explain how to reproduce this in detail?

thanks!
Comment 6 Itxaka 2016-04-26 08:24:55 EDT
I am unable to reproduce this.

Could we get a bit more explanation on how to reproduce this?

Where are you going to the console link from? From the instances page? From the network topology page?

Note that in both cases I could reach the proper console for the selected instance so it feels like Im missing some steps in here.

Could you try and explain how to reproduce this in detail?

thanks!
Comment 7 Matthias Runge 2016-06-23 09:02:42 EDT
two months here since needinfo, no response. Please re-open, once you could provide more details.

Note You need to log in before you can comment on or make changes to this bug.