Bug 1305740 - No module named hardware_hal in rhn-client-tools causing a crash
No module named hardware_hal in rhn-client-tools causing a crash
Status: CLOSED DUPLICATE of bug 1305073
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomáš Kašpárek
Red Hat Satellite QA List
:
Depends On:
Blocks: 1306715
  Show dependency treegraph
 
Reported: 2016-02-09 00:30 EST by Steeve Goveas
Modified: 2016-05-26 16:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1306715 (view as bug list)
Environment:
Last Closed: 2016-03-09 08:02:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash directory (4.85 MB, application/x-gzip)
2016-02-09 00:33 EST, Steeve Goveas
no flags Details

  None (edit)
Description Steeve Goveas 2016-02-09 00:30:24 EST
Actual results:

abrt_version:   2.1.11
cmdline:        python /usr/share/rhn/up2date_client/hardware.py
executable:     /usr/share/rhn/up2date_client/hardware.py
hostname:       auto-hv-01-guest08.testrelm.test
kernel:         3.10.0-123.el7.x86_64
last_occurrence: 1454934122
pid:            2591
pkg_arch:       noarch
pkg_epoch:      0
pkg_name:       rhn-client-tools
pkg_release:    5.el7
pkg_version:    2.0.2
runlevel:       N 3
time:           Mon 08 Feb 2016 07:22:02 AM EST
uid:            0
username:       root

sosreport.tar.xz: Binary file, 5078224 bytes

abrt-crashdir-link:
:ftp://auto-hv-01.idmqe.lab.eng.bos.redhat.com/hardware.py.2591.1454934122.auto-hv-01-guest08.testrelm.test.core.gz
:

abrt-faf-report:
:uReport: BTHASH=64970911b241ca64bc8eec6c89ea369ef2d8cc15
:ABRT Server: URL=http://faf-report.itos.redhat.com/reports/bthash/64970911b241ca64bc8eec6c89ea369ef2d8cc15

backtrace:
:hardware.py:45:<module>:ImportError: No module named hardware_hal
:
:Traceback (most recent call last):
:  File "/usr/share/rhn/up2date_client/hardware.py", line 45, in <module>
:    from hardware_hal import check_hal_dbus_status, get_hal_computer, read_hal
:ImportError: No module named hardware_hal
:
:Local variables in innermost frame:
:AF_INET6: 10
:getaddrinfo: <built-in function getaddrinfo>
:rhnserver: <module 'rhnserver' from '/usr/share/rhn/up2date_client/rhnserver.pyc'>
:gethostname: <built-in function gethostname>
:up2dateLog: <module 'up2dateLog' from '/usr/share/rhn/up2date_client/up2dateLog.pyc'>
:gettext: <module 'gettext' from '/usr/lib64/python2.7/gettext.pyc'>
:__package__: None
:re: <module 're' from '/usr/lib64/python2.7/re.pyc'>
:config: <module 'config' from '/usr/share/rhn/up2date_client/config.pyc'>
:__doc__: 'Used to read hardware info from kudzu, /proc, etc'
:ethtool: <module 'ethtool' from '/usr/lib64/python2.7/site-packages/ethtool.so'>
:__builtins__: <module '__builtin__' (built-in)>
:__file__: '/usr/share/rhn/up2date_client/hardware.py'
:sys: <module 'sys' (built-in)>
:dmidecode: <module 'dmidecode' from '/usr/lib64/python2.7/site-packages/dmidecode.pyc'>
:ethtool_present: True
:__name__: '__main__'
:_: <bound method NullTranslations.ugettext of <gettext.NullTranslations instance at 0x1340998>>
:socket: <module 'socket' from '/usr/lib64/python2.7/socket.pyc'>
:dbus: <module 'dbus' from '/usr/lib64/python2.7/site-packages/dbus/__init__.pyc'>
:AF_INET: 2
:t: <gettext.NullTranslations instance at 0x1340998>
:os: <module 'os' from '/usr/lib64/python2.7/os.pyc'>

Expected results:


Additional info:
Comment 1 Steeve Goveas 2016-02-09 00:33 EST
Created attachment 1122341 [details]
Crash directory
Comment 3 Tomas Lestach 2016-03-09 08:02:08 EST
According to:
cmdline:        python /usr/share/rhn/up2date_client/hardware.py
this looks like a duplicate of Bug 1305073. Closing.

*** This bug has been marked as a duplicate of bug 1305073 ***
Comment 4 Hai Nguyen 2016-05-26 16:28:02 EDT
I don't see a resolution for this. Would you please provide more information as how to deal with these crashes?

Note You need to log in before you can comment on or make changes to this bug.