This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1305775 - [UI] Task detail steps counter is hardcoded [NEEDINFO]
[UI] Task detail steps counter is hardcoded
Status: CLOSED WONTFIX
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI (Show other bugs)
2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3
Assigned To: Sankarshan Mukhopadhyay
Daniel Horák
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 03:40 EST by Daniel Horák
Modified: 2017-03-23 00:10 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhscon-ceph-0.0.23-1.el7scon.x86_64, rhscon-core-0.0.24-1.el7scon.x86_64, rhscon-ui-0.0.39-1.el7scon.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-23 00:10:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mbukatov: needinfo? (sankarshan)


Attachments (Terms of Use)
Task detail page (126.24 KB, image/png)
2016-02-09 03:40 EST, Daniel Horák
no flags Details
Task detail page (few steps). (39.03 KB, image/png)
2016-02-09 03:41 EST, Daniel Horák
no flags Details
Task Detail page - missing progress bar and steps counter (49.35 KB, image/png)
2016-07-22 02:44 EDT, Daniel Horák
no flags Details

  None (edit)
Description Daniel Horák 2016-02-09 03:40:01 EST
Created attachment 1122355 [details]
Task detail page

Description of problem:
  Task detail page contain step counter in the form "In Progress Step 2 of 7" with blue progress bar, neither of this works.


Version-Release number of selected component (if applicable):
  rhscon-ceph-0.0.6-2.el7.x86_64
  rhscon-core-0.0.8-2.el7.x86_64
  rhscon-ui-0.0.11-1.el7.noarch


How reproducible:
  100%

Steps to Reproduce:
1. In USM web UI accept few nodes, create cluster and some storage.
2. Go to the "Tasks" page (flag icon in the upper right corner -> See All)
3. Click on "Details" for some tasks.

Actual results:
  The status is always "In Progress" and the step counter shows "Step 2 of 7", no matter which task is it, in which state and how many steps it contains.

Expected results:
  Task status, steps counter and progress bar will show real data.

Additional info:
Comment 1 Daniel Horák 2016-02-09 03:41 EST
Created attachment 1122356 [details]
Task detail page (few steps).
Comment 4 Daniel Horák 2016-07-22 02:44 EDT
Created attachment 1182717 [details]
Task Detail page - missing progress bar and steps counter

Moving back to ASSIGNED, because the "steps counter" was completely removed - which is in contradiction with design document.
Comment 6 Daniel Horák 2016-07-22 02:49:57 EDT
Moving to ASSIGNED as peer Comment 4.

If this is the resolution for this BZ, please update the design document or at least add comment there, that it was decided to change the design/functionality in contradiction with the design.
Comment 7 Martin Bukatovic 2016-07-22 04:00:32 EDT
After quickly review of this BZ, I think that it was moved to ON_QA by mistake.

As it seems to me that this BZ is blocked by BZ 1335631. In other words, the
progress bar with counter would make sense only when the original design
is followed. Moreover the current implementation doesn't provide a clear
idea of predefined set of steps which may be the reason why the progress bar
was removed in the end.

Could the dev team check my suggestion and if there is an agreement, link
this BZ as blocked by BZ 1335631 and move it to 3.0?

Note You need to log in before you can comment on or make changes to this bug.