Bug 1305874 - [abrt] docker-compose: network.py:7:<module>:ImportError: cannot import name create_ipam_config
[abrt] docker-compose: network.py:7:<module>:ImportError: cannot import name ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: docker-compose (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Hampton
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:38087749a7b1b6e0984725f566c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 08:14 EST by Jiri Popelka
Modified: 2016-02-10 06:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 06:50:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (8.44 KB, text/plain)
2016-02-09 08:14 EST, Jiri Popelka
no flags Details

  None (edit)
Description Jiri Popelka 2016-02-09 08:14:38 EST
Description of problem:
docker-compose up

Version-Release number of selected component:
docker-compose-1.6.0-1.fc23

Additional info:
reporter:       libreport-2.6.4
cmdline:        /usr/bin/python2 /usr/bin/docker-compose up
dso_list:       python-setuptools-18.0.1-2.fc23.noarch
executable:     /usr/bin/docker-compose
kernel:         4.3.5-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
#1 <module> in /usr/lib/python2.7/site-packages/compose/network.py:7
#2 <module> in /usr/lib/python2.7/site-packages/compose/project.py:21
#3 <module> in /usr/lib/python2.7/site-packages/compose/cli/main.py:26
#4 resolve in /usr/lib/python2.7/site-packages/pkg_resources/__init__.py:2361
#5 load in /usr/lib/python2.7/site-packages/pkg_resources/__init__.py:2355
#6 load_entry_point in /usr/lib/python2.7/site-packages/pkg_resources/__init__.py:2682
#7 load_entry_point in /usr/lib/python2.7/site-packages/pkg_resources/__init__.py:558
#8 <module> in /usr/bin/docker-compose:9
Comment 1 Jiri Popelka 2016-02-09 08:14:43 EST
Created attachment 1122403 [details]
File: backtrace
Comment 3 Jiri Popelka 2016-02-09 08:26:42 EST
docker-compose-1.6.0 requires python-docker-py >= 1.7.0rc3
Comment 4 Tomas Tomecek 2016-02-09 09:50:10 EST
docker-py 1.7.0 is built in rawhide; there will be a docker-py 1.7.1 release soon

I think that I can put docker-py 1.7.1 to 23 once it's released
Comment 5 Jiri Popelka 2016-02-10 06:50:23 EST
Closing as this has been updates-testing problem only and the update has been unpushed.

Note You need to log in before you can comment on or make changes to this bug.