Bug 130594 - Program mprime in GIMPS project does not run
Program mprime in GIMPS project does not run
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-22 11:55 EDT by Richard Steck
Modified: 2015-01-04 17:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:01:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output of mprime (from mprime235.tar.gz) segfaulting on kernel 521 (3.07 KB, text/plain)
2004-08-23 09:13 EDT, Barry K. Nathan
no flags Details
strace output of mprime (from sprime235.tar.gz) segfaulting on kernel 521 (1.79 KB, text/plain)
2004-08-23 09:14 EDT, Barry K. Nathan
no flags Details

  None (edit)
Description Richard Steck 2004-08-22 11:55:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
GIMPS is the Great Internet Prime Search, a distributed computing 
program widely used to search for prime numbers.

The main program, mprime, works with  2.6.7-1.494.2.2  and with prior 
kernels but does not work with  2.6.8-1.521.  The program aborts with 
a shell signal 11.

I tried this on two machines, so I am pretty sure there is a problem.



Version-Release number of selected component (if applicable):
kernel-2.6.8-1.521

How reproducible:
Always

Steps to Reproduce:
1.run  mprime in terminal mode
2.
3.
    

Actual Results:  Program aborts with signal 11.

Expected Results:  Should have entered into prime number computation.

Additional info:
Comment 1 Arjan van de Ven 2004-08-22 12:02:04 EDT
can you attach a strace of this app?
Is it available for download somewhere ?
Comment 2 Barry K. Nathan 2004-08-23 09:11:57 EDT
Download page:
http://www.mersenne.org/freesoft.htm

I will be attaching strace output in the next few minutes.
Comment 3 Barry K. Nathan 2004-08-23 09:13:30 EDT
Created attachment 102979 [details]
strace output of mprime (from mprime235.tar.gz) segfaulting on kernel 521
Comment 4 Barry K. Nathan 2004-08-23 09:14:49 EDT
Created attachment 102980 [details]
strace output of mprime (from sprime235.tar.gz) segfaulting on kernel 521
Comment 5 Richard Steck 2004-08-23 21:47:18 EDT
Thank you for showing me the strace.  I am a newbie. 
 
Please tell me if the mprime problem I reported is due to mprime, due 
to the 2.6.8-1.521 kernel or somewhere else. 
 
Thank you for your help.  The GIMPS project and mprime are widely 
used 
Comment 6 Barry K. Nathan 2004-09-18 07:26:17 EDT
---begin quote---
New features in Version 23.9 of mprime
--------------------------------------

1)  Fixed mprime crash bug that arose when Fedora users upgraded to
    kernel 2.6.8-1.520.
---end quote---

(quoting from whatsnew.txt in mprime239.tar.gz)

There's a new release of mprime on the mersenne.org web site. I
haven't tried it yet, but the release notes indicate that it should
fix the crash.
Comment 7 Dave Jones 2005-04-16 01:01:26 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.
Comment 8 Barry K. Nathan 2005-05-19 04:14:49 EDT
For the sake of completing the historical record:

The bug was in a third-party program (mprime) which is not shipped in RHEL or
Fedora Core and which has since been corrected (as I mentioned in comment #6; I
have since tested that fix and confirmed that the fix is effective).

Note You need to log in before you can comment on or make changes to this bug.