Bug 1306101 - RHEL 7.1 docker 1.8.2 missing libdevmapper dependency
RHEL 7.1 docker 1.8.2 missing libdevmapper dependency
Status: CLOSED DUPLICATE of bug 1306100
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.1
x86_64 Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Daniel Walsh
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 20:55 EST by Øystein Bedin
Modified: 2016-02-09 21:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-09 21:07:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Øystein Bedin 2016-02-09 20:55:33 EST
Description of problem:
When using a RHEL7.1 system to install docker, it fails with a missing libdevmapper dependency. 

Version-Release number of selected component (if applicable):
RHEL: 7.1
Docker: 1.8.2-10
device-mapper-libs: libdevmapper.so.1.02(DM_1_02_97)

How reproducible:
Install a RHEL 7.1 system, lock it to 7.1 using "subscription-manager release" then attempt a "yum install docker".

Steps to Reproduce:
1. Install RHEL 7.1
2. Use "subscription-manager release --set=7.1" to lock it in on 7.1
3. Use "yum install docker" to see the error in dependencies

Actual results:
# yum install docker
Resolving Dependencies
--> Running transaction check
---> Package docker.x86_64 0:1.8.2-10.el7 will be installed
--> Processing Dependency: docker-selinux >= 1.8.2-10.el7 for package: docker-1.8.2-10.el7.x86_64
--> Processing Dependency: libdevmapper.so.1.02(DM_1_02_97)(64bit) for package: docker-1.8.2-10.el7.x86_64
--> Running transaction check
---> Package docker.x86_64 0:1.8.2-10.el7 will be installed
--> Processing Dependency: libdevmapper.so.1.02(DM_1_02_97)(64bit) for package: docker-1.8.2-10.el7.x86_64
---> Package docker-selinux.x86_64 0:1.8.2-10.el7 will be installed
--> Finished Dependency Resolution
Error: Package: docker-1.8.2-10.el7.x86_64 (rhel-7-server-extras-rpms)
           Requires: libdevmapper.so.1.02(DM_1_02_97)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
Docker should install A_OK on RHEL 7.1

Additional info:
Comment 2 Øystein Bedin 2016-02-09 21:07:34 EST

*** This bug has been marked as a duplicate of bug 1306100 ***

Note You need to log in before you can comment on or make changes to this bug.