Bug 1306170 - haproxy connection logs shown under swift.log file
haproxy connection logs shown under swift.log file
Status: CLOSED DUPLICATE of bug 1287325
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
All Unspecified
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: Angus Thomas
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 03:44 EST by bkopilov
Modified: 2016-04-18 03:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 05:05:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bkopilov 2016-02-10 03:44:44 EST
Description of problem:

In OSP-D HA setup , swift.log reports about all haproxy connections ...  

Seems strange to me ?  am i wrong ?


/var/log/swift/swift.log:54910:Feb 10 02:45:35 localhost haproxy[6696]: Connect from 192.168.1.62:58324 to 192.168.1.101:5000 (keystone_public/HTTP)
/var/log/swift/swift.log:55043:Feb 10 02:48:21 localhost haproxy[6696]: Connect from 172.17.1.13:38696 to 172.17.1.11:5000 (keystone_public/HTTP)
/var/log/swift/swift.log:55062:Feb 10 02:48:30 localhost haproxy[6696]: Connect from 192.168.1.62:59603 to 192.168.1.101:5000 (keystone_public/HTTP)
/var/log/swift/swift.log:55126:Feb 10 02:50:02 localhost haproxy[6696]: Connect from 192.168.1.62:60263 to 192.168.1.101:5000 (keystone_public/HTTP)
/var/log/swift/swift.log:55172:Feb 10 02:50:59 localhost haproxy[6696]: Connect from 172.17.1.11:34093 to 172.17.1.11:5000 (keystone_public/HTTP)

/var/log/swift/swift.log:57304:Feb 10 03:31:00 localhost haproxy[6696]: Connect from 192.168.1.101:60494 to 192.168.1.101:9696 (neutron/TCP)
/var/log/swift/swift.log:57305:Feb 10 03:31:00 localhost haproxy[6696]: Connect from 192.168.1.101:60496 to 192.168.1.101:9696 (neutron/TCP)
/var/log/swift/swift.log:57311:Feb 10 03:31:00 localhost haproxy[6696]: Connect from 192.168.1.101:60521 to 192.168.1.101:9696 (neutron/TCP)
/var/log/swift/swift.log:57312:Feb 10 03:31:00 localhost haproxy[6696]: Connect from 192.168.1.101:60523 to 192.168.1.101:9696 (neutron/TCP)
/var/log/swift/swift.log:57315:Feb 10 03:31:01 localhost haproxy[6696]: Connect from 192.168.1.101:60527 to 192.168.1.101:9696 (neutron/TCP)
/var/log/swift/swift.log:57322:Feb 10 03:31:01 localhost haproxy[6696]: Connect from 192.168.1.101:60545 to 192.168.1.101:9696 (neutron/TCP)
/var/log/swift/swift.log:57323:Feb 10 03:31:02 localhost haproxy[6696]: Connect from 192.168.1.101:60547 to 192.168.1.101:9696 (neutron/TCP)

from swift.log file  , reporting about haproxy ?

Feb 10 03:31:02 localhost haproxy[6696]: Connect from 192.168.1.101:52954 to 192.168.1.101:8080 (swift_proxy_server/TCP)
Feb 10 03:31:02 localhost proxy-server: 172.17.3.13 172.17.3.13 10/Feb/2016/08/31/02 GET /v1/AUTH_32efc0ebb944433aa319c5e5c50ac8cb%3Fformat%3Djson HTTP/1.0 403 - python-swiftclient-2.4.0 cce5de1742874f9e... - 73 - txa3a87a1ed22e4997890f6-0056baf546 - 0.0003 - - 1455093062.661480904 1455093062.661783934 -
Feb 10 03:31:02 localhost haproxy[6696]: Connect from 192.168.1.101:60574 to 192.168.1.101:9696 (neutron/TCP)
Feb 10 03:31:02 localhost haproxy[6696]: Connect from 172.17.1.11:56730 to 172.17.1.11:5000 (keystone_public/HTTP)
Feb 10 03:31:02 localhost haproxy[6696]: Connect from 192.168.1.101:60579 to 192.168.1.101:9696 (neutron/TCP)
Feb 10 03:31:03 localhost haproxy[6696]: Connect from 192.168.1.101:50686 to 192.168.1.101:8774 (nova_osapi/HTTP)
Feb 10 03:31:03 localhost haproxy[6696]: Connect from 172.17.1.11:55845 to 172.17.1.11:9696 (neutron/TCP)
Feb 10 03:31:03 localhost haproxy[6696]: Connect from 192.168.1.101:52969 to 192.168.1.101:8080 (swift_proxy_server/TCP)
Feb 10 03:31:03 localhost proxy-server: 172.17.3.13 172.17.3.13 10/Feb/2016/08/31/03 HEAD /v1/AUTH_32efc0ebb944433aa319c5e5c50ac8cb HTTP/1.0 403 - python-swiftclient-2.4.0 cce5de1742874f9e... - - - tx28e81019317d4701bfeaf-0056baf547 - 0.0003 - - 1455093063.545180082 1455093063.545491934 -


from rsyslog :
/etc/rsyslog.d/openstack-swift.conf:4:local0.*;local1.*;local2.*   /var/log/swift/swift.log



Version-Release number of selected component (if applicable):


How reproducible:
Install latest openstack director.

Steps to Reproduce:
1. Install HA setup on OSP-D 
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 bkopilov 2016-02-10 05:05:41 EST

*** This bug has been marked as a duplicate of bug 1287325 ***

Note You need to log in before you can comment on or make changes to this bug.