Bug 1306261 - [scale] - after prolonged use large memory growth in firefox
[scale] - after prolonged use large memory growth in firefox
Status: CLOSED DUPLICATE of bug 1294678
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.2.5
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.6
: ---
Assigned To: Greg Sheremeta
mlehrer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 07:38 EST by mlehrer
Modified: 2016-03-16 03:29 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-16 03:29:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑3.6.z?
oourfali: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
pstehlik: testing_ack+


Attachments (Terms of Use)
Firefox Memory tree, growth over time, and raw mem report (334.79 KB, application/zip)
2016-02-10 07:38 EST, mlehrer
no flags Details

  None (edit)
Description mlehrer 2016-02-10 07:38:58 EST
Created attachment 1122781 [details]
Firefox Memory tree, growth over time, and raw mem report

Description of problem:
Firefox tab running ovirt becomes sluggish and non-responsive due to high memory use in firefox.  Forcing user to close and re-open tab to improve sluggishness after prolonged use, which then re-occurs again.

Attached 
-majority of memory contained by orphan nodes (530mb of total 1.1GB )
-memory growth of firefox process over time including effect of tab close shown


Version-Release number of selected component (if applicable):


Firefox version: 43.0.3

ovirt-vmconsole-proxy-1.0.0-1.el6ev.noarch
libgovirt-0.3.2-1.el6.x86_64
rhevm-setup-plugin-ovirt-engine-common-3.6.2.5-0.1.el6.noarch
ovirt-engine-extension-aaa-jdbc-1.0.5-1.el6ev.noarch
ovirt-setup-lib-1.0.1-1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-3.6.2.5-0.1.el6.noarch
ovirt-host-deploy-java-1.4.1-1.el6ev.noarch
ovirt-host-deploy-1.4.1-1.el6ev.noarch
ovirt-vmconsole-1.0.0-1.el6ev.noarch


How reproducible:
Takes some time to reproduce, and requires populated system. 
Env:
30 ISCSI Data Domains
20 NFS Data Domains
1 VM pool of 15 VMs
1 VM pool of 20 Vms
9 VMs 

Steps to Reproduce:
1. Browse through list of VMs wait 5-10 mins
2. Browse through list of storage domains wait 5-10 mins
3. Edit Storage or Vms, wait for 5-10 mins
4. Browse more though Vms/Domains 

After 45 mins or so of intermittent use of browsing, editing storage domains, and vms the user experience becomes sluggish and hard to use.  Memory growth should be detectable throughout use.

1 FF Tab is used, and must remain open for the duration of the test.
Meaning closing the tab, frees up memory. 

Actual results:

See attachment, memory foot print high, user experience choppy, sluggish forcing user to close tab and re-log in for better experience.

Expected results:
Lower memory foot print, and no choppy/sluggishness after continued use.

Additional info:

Likely related to https://bugzilla.redhat.com/show_bug.cgi?id=1294678
Comment 1 Oved Ourfali 2016-02-10 09:52:36 EST
Mordechai - can you test also 3.5?
Comment 2 Oved Ourfali 2016-02-11 03:54:15 EST
Until you can verify that's a regression, this isn't urgent.
Please prioritize work of the scale team to test it in a real 3.5 environment.
Comment 5 Oved Ourfali 2016-03-16 03:29:55 EDT

*** This bug has been marked as a duplicate of bug 1294678 ***

Note You need to log in before you can comment on or make changes to this bug.