Bug 1306262 - Images written in Windows don't succeed in online media check
Images written in Windows don't succeed in online media check
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 07:38 EST by Martin Bříza
Modified: 2016-02-10 10:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 08:36:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Bříza 2016-02-10 07:38:59 EST
Description of problem:
When you use dd (either the Delphi version by Chrysocome or the one shipped with Cygwin) to write a Fedora Live image to a flash drive, it fails the media check that is ran when you choose the "Test the media and start Fedora Live" option (the default).

Version-Release number of selected component (if applicable):
Fedora-*-23-11.iso media are affected

How reproducible:
Always

Steps to Reproduce:
1. Use dd to write your Fedora live image to a flash drive (i.e. dd if=Fedora-<something>.iso of=\\\\.\\PHYSICALDRIVE1)
2. Reboot and boot to the portable drive

Actual results:
Media check fails

Expected results:
Media check succeeds

Additional info:
This is caused by the fact Windows (seems this behavior is present since Windows 8.1) creates a "System Volume Information" folder on every drive that's connected to the system, so even this fresh drive. This folder then makes the media check fail.

Possible solutions are:
1) To provide our own System Volume Information folder that's not writable or in some other way prevent its creation/modification
2) Change the way checkisomd5 works with this folder
3) Tell the users to turn this Windows feature off
Comment 1 Martin Bříza 2016-02-10 08:00:56 EST
Oh, forgot to mention this is related to the second partition - the EFI labeled one.
Comment 2 Martin Bříza 2016-02-10 08:36:01 EST
Ok, I think I found a way to prevent this, a while after reporting the bug. Closing for now and will report back with details
Comment 3 Brian Lane 2016-02-10 10:53:29 EST
Use liveusb-creator to make usb drives on windows - https://fedorahosted.org/liveusb-creator/. If Windows is adding things to the drive then it isn't really a dd operation.
Comment 4 Martin Bříza 2016-02-10 10:56:50 EST
I'm maintaining the liveusb-creator and I'm trying to write a working dd backend so it behaves the same on all platforms.
Regarding this issue, it seems you just have to force-unmount the drive after dd-ing it to prevent the folder from appearing.

Note You need to log in before you can comment on or make changes to this bug.