Bug 1306410 - Upgrade tmuxinator to the latest 0.6.x
Upgrade tmuxinator to the latest 0.6.x
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tmuxinator (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Miller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 13:40 EST by Dridi Boukelmoune
Modified: 2016-04-21 21:51 EDT (History)
1 user (show)

See Also:
Fixed In Version: tmuxinator-0.6.11-1.fc23 tmuxinator-0.6.11-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 21:26:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dridi Boukelmoune 2016-02-10 13:40:45 EST
Description of problem:
This package currently ships with a 2-year old upstream release. According to the current master branch, upstream is following semantic versioning [1] so it should be possible to update from 0.6.8 to 0.6.11 (and to 0.7.0 for rawhide).

Version-Release number of selected component (if applicable):
tmuxinator-0.6.8-1.fc22.noarch
tmuxinator-0.6.8-2.fc23.noarch


Expected results:
Being able to use a specific root per window and ERB templates :)

Additional info:

I have a package ready for testing with this diff:

===
diff --git a/tmuxinator.spec b/tmuxinator.spec
index 0f069bf..ffea552 100644
--- a/tmuxinator.spec
+++ b/tmuxinator.spec
@@ -2,13 +2,13 @@
 %global gem_name tmuxinator
 
 Name: %{gem_name}
-Version: 0.6.8
+Version: 0.6.11
 Release: 1%{?dist}
 Summary: Create and manage complex tmux sessions easily
 Group: Development/Languages
 License: MIT
 URL: https://github.com/aziz/tmuxinator
-Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
+Source0: https://rubygems.org/downloads/%{gem_name}-%{version}.gem
 Requires: ruby(release)
 Requires: ruby(rubygems) >= 1.8.23
 Requires: rubygem(thor) >= 0.18.0
@@ -17,13 +17,14 @@ Requires: tmux
 BuildRequires: ruby(release)
 BuildRequires: rubygems-devel >= 1.8.23
 BuildRequires: ruby 
-BuildRequires: rubygem(rspec) >= 2.14.0
+BuildRequires: rubygem(rspec-core)
 # BuildRequires: rubygem(simplecov) 
 # BuildRequires: rubygem(coveralls) 
 # BuildRequires: rubygem(awesome_print) 
 # BuildRequires: rubygem(pry) 
 # BuildRequires: rubygem(pry-nav) 
 # BuildRequires: rubygem(factory_girl) 
+# BuildRequires: rubygem(erubis)
 BuildArch: noarch
 Provides: rubygem(%{gem_name}) = %{version}
 
@@ -67,7 +68,7 @@ cp -a .%{_bindir}/* \
 
 find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x
 
-# FIXME: Test suite not currently run because it requires rubygem-coveralls
+# FIXME: Test suite not currently run because it requires rubygem-pry-nav
 # which at the time of this writing is not available in Fedora.
 #
 # Run the test suite
@@ -77,14 +78,6 @@ find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x
 #popd
 
 %files
-%doc %{gem_instdir}/CHANGELOG.md
-%doc %{gem_instdir}/CONTRIBUTING.md
-%doc %{gem_instdir}/Gemfile
-%doc %{gem_instdir}/LICENSE
-%doc %{gem_instdir}/README.md
-%doc %{gem_instdir}/Rakefile
-%doc %{gem_instdir}/tmuxinator.gemspec
-
 %dir %{gem_instdir}
 %{gem_instdir}
 %{_bindir}/mux
@@ -92,9 +85,6 @@ find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x
 %{gem_instdir}/bin
 %{gem_libdir}
 %exclude %{gem_cache}
-%exclude %{gem_instdir}/.gitignore
-%exclude %{gem_instdir}/.rspec
-%exclude %{gem_instdir}/.travis.yml
 %{gem_spec}
 
 %files doc
===

I am currently running tmuxinator 0.6.11 on my system with the patch above and it's working fine and as expected. I'll update this ticket if I find an issue.

I could run the test suite during the build, but it failed. Most likely because of a missing package, which I think is the last missing bit.

Thanks,
Dridi

[1] https://github.com/tmuxinator/tmuxinator/blob/719189c/.rubocop.yml#L335
Comment 1 Dridi Boukelmoune 2016-02-13 05:03:11 EST
I just noticed the new project URL is https://github.com/tmuxinator/tmuxinator

Regards,
Dridi
Comment 2 Fedora Update System 2016-02-25 14:35:57 EST
tmuxinator-0.6.11-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9c2f1cc5e2
Comment 3 Fedora Update System 2016-02-25 14:35:58 EST
tmuxinator-0.6.11-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-676460a7b7
Comment 4 Fedora Update System 2016-02-25 14:36:00 EST
tmuxinator-0.6.11-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-676460a7b7
Comment 5 Fedora Update System 2016-02-26 15:51:38 EST
tmuxinator-0.6.11-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-676460a7b7
Comment 6 Fedora Update System 2016-02-26 15:52:33 EST
tmuxinator-0.6.11-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9c2f1cc5e2
Comment 7 Fedora Update System 2016-04-21 21:26:21 EDT
tmuxinator-0.6.11-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2016-04-21 21:51:40 EDT
tmuxinator-0.6.11-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.