Bug 1306419 - Unit tests for shade are failing
Unit tests for shade are failing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-shade (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Belanger
Fedora Extras Quality Assurance
:
Depends On: 1315111
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 14:29 EST by Paul Belanger
Modified: 2016-04-20 10:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-20 10:05:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
current version of local spec (5.06 KB, patch)
2016-02-10 14:34 EST, Paul Belanger
no flags Details | Diff

  None (edit)
Description Paul Belanger 2016-02-10 14:29:15 EST
Currently, the shades that ship with shade are failing.  This is because we are not using os-client-config >=1.13.0

FAIL: shade.tests.unit.test_users.TestUsers.test_is_user_in_group
tags: worker-7
----------------------------------------------------------------------
Empty attachments:
  pythonlogging:''
  stderr
  stdout

Traceback (most recent call last):
  File "/builddir/build/BUILD/shade-1.4.0/shade/tests/unit/test_users.py", line 31, in setUp
    self.cloud = shade.operator_cloud(validate=False)
  File "/builddir/build/BUILD/shade-1.4.0/shade/__init__.py", line 92, in operator_cloud
    return OperatorCloud(cloud_config=cloud_config)
  File "/builddir/build/BUILD/shade-1.4.0/shade/operatorcloud.py", line 35, in __init__
    super(OperatorCloud, self).__init__(*args, **kwargs)
  File "/builddir/build/BUILD/shade-1.4.0/shade/openstackcloud.py", line 169, in __init__
    cache_expiration_time = int(cloud_config.get_cache_expiration_time())
TypeError: 'NoneType' object is not callable
Comment 1 Paul Belanger 2016-02-10 14:30:19 EST
The fix is to bump os-client-config >=1.13.0. I am currently working on that.
Comment 2 Paul Belanger 2016-02-10 14:34 EST
Created attachment 1122890 [details]
current version of local spec
Comment 3 Jan Kurik 2016-02-24 09:28:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Note You need to log in before you can comment on or make changes to this bug.