Bug 1306427 - dracut is unable to boot while doing BFO install, drops to dracut shell
dracut is unable to boot while doing BFO install, drops to dracut shell
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Václav Pavlín
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 15:39 EST by stan
Modified: 2016-02-16 12:57 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-15 10:04:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the report that dracut generated when the error occurred. (109.74 KB, text/plain)
2016-02-10 15:39 EST, stan
no flags Details
File that dracut generated on failure (140.06 KB, text/plain)
2016-02-16 12:51 EST, stan
no flags Details
journalctl -r output from failure (101.40 KB, text/plain)
2016-02-16 12:52 EST, stan
no flags Details

  None (edit)
Description stan 2016-02-10 15:39:51 EST
Created attachment 1122895 [details]
This is the report that dracut generated when the error occurred.

Description of problem:
While using BFO to do an install of rawhide, the system gets to the point where it says basic system installed.  It then goes into dracut timeouts, and drops to a dracut shell.


Version-Release number of selected component (if applicable):
dracut-044-17.git20160108.fc24

How reproducible:
Happens about half the time when doing a BFO install.  Seems to happen every time with slow download of OS, almost never when download is fast.

Steps to Reproduce:
1.  Do a BFO install of rawhide x86_64
2.  If downloads are slow, the usual case, pretty good chance this error will happen
3.

Actual results:
See this error

Expected results:
Proceed to download of stage2 and anaconda install

Additional info:
The information that comes up at the dracut shell prompt when help is typed is misleading.  It would be better to do an ls of the /bin directory and tell the user that those are the commands available.
Comment 2 Martin Kolman 2016-02-12 06:02:37 EST
I think that in this case BFO means: https://boot.fedoraproject.org/
Comment 3 David Shea 2016-02-12 09:14:35 EST
Looks like the rd.timeout in the boot.fedoraproject.org needs to be increased.
Comment 4 Kevin Fenzi 2016-02-12 16:26:27 EST
Well, there's currently no timeout set... what would you recommend we set it to?
Comment 5 stan 2016-02-13 15:36:32 EST
I notice that when the downloads take about 5 minutes, this error doesn't occur.  When they are slow, taking several hours, it usually occurs.  The speed ratio between the two is about 50, so I suggest a 60 second timeout, which gives a little room for error.
Comment 6 Kevin Fenzi 2016-02-15 10:04:03 EST
Done. Please test and let me know if there's still any issue...
Comment 7 stan 2016-02-15 13:15:59 EST
Thanks.  I'll try it tonight.
Comment 8 stan 2016-02-16 12:51 EST
Created attachment 1127658 [details]
File that dracut generated on failure
Comment 9 stan 2016-02-16 12:52 EST
Created attachment 1127659 [details]
journalctl -r output from failure
Comment 10 stan 2016-02-16 12:54:23 EST
The same error occurred, but when I looked in journalctl I saw that the download had failed.  I watched if for a few minutes when I started it, and it was running at about 66KB/sec.  But it stopped shortly after I left it unattended.  It might have been because of maintenance.


Feb 16 05:57:10 localhost dracut-initqueue[696]: Warning: /dev/root does not exist
Feb 16 05:57:10 localhost systemd[1]: Received SIGRTMIN+20 from PID 700 (plymouthd).
Feb 16 05:57:09 localhost dracut-initqueue[696]: Warning: Could not boot.


 losetup: /tmp/curl_fetch_url1/install.img: Warning: file does not fit into a 512-byte sector; the end of the file will be ignored.
Feb 16 05:54:05 localhost kernel: loop: module loaded
Feb 16 05:54:03 localhost dracut-initqueue[696]: curl: (18) transfer closed with 379650412 bytes remaining to read
Feb 16 05:54:03 localhost dracut-initqueue[696]: [1.9K blob data]
Feb 16 05:53:40 localhost dracut-initqueue[696]: [1.9K blob data]
Feb 16 05:53:14 localhost dracut-initqueue[696]: [2.0K blob data]
Feb 16 05:52:47 localhost dracut-initqueue[696]: [1.9K blob data]
Feb 16 05:52:21 localhost dracut-initqueue[696]: [2.0K blob data]
Feb 16 05:51:55 localhost dracut-initqueue[696]: [2.0K blob data]
Feb 16 05:51:29 localhost dracut-initqueue[696]: [2.0K blob data]
Feb 16 05:51:03 localhost dracut-initqueue[696]: [2.0K blob data]
Feb 16 05:50:37 localhost dracut-initqueue[696]: [2.0K blob data]
Feb 16 05:50:11 localhost dracut-initqueue[696]: [237B blob data]
Feb 16 05:50:11 localhost dracut-initqueue[696]:                                  Dload  Upload   Total   Spent    Left  Speed
Feb 16 05:50:11 localhost dracut-initqueue[696]:   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
Feb 16 05:50:11 localhost dracut-initqueue[696]: Warning: can't find installer mainimage path in .treeinfo
Feb 16 05:50:10 localhost dracut-initqueue[696]: anaconda fetching installer from http://download.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os/
Feb 16 05:50:09 localhost dracut-initqueue[696]: RTNETLINK answers: File exists

I ran this morning, and even though there were a couple of lulls with no transmission, the download completed, and I was able to get into anaconda.  Where I had an error I've been getting and reported it in another bugzilla.

The download speed was about 138kB/sec, so took about 45 minutes total.  That seems like an adequate test.

So, this is probably fixed, but I'll continue to monitor it as I try to complete a rawhide installation using BFO.

Note You need to log in before you can comment on or make changes to this bug.