Bug 1306472 - Touchpad stays disabled if "Disable While Typing" is unset while disabled
Touchpad stays disabled if "Disable While Typing" is unset while disabled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-libinput (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 18:25 EST by Andrew Cook
Modified: 2016-02-10 19:03 EST (History)
2 users (show)

See Also:
Fixed In Version: libinput-1.1.7-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 19:03:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Cook 2016-02-10 18:25:58 EST
Description of problem:
Touchpad stays disabled if "Disable While Typing" is unset while disabled because of typng

Version-Release number of selected component (if applicable):
xorg-x11-drv-libinput 0.16.0-2.fc24 
libinput 1.1.6-1.fc24 

How reproducible:
Always

Steps to Reproduce:
1. Open a terminal within x
2. Run xinput set-prop [id] 286 0
   id can be discovered from xinput list

Actual results:
Mouse is locked until disable while typing is re-enabled

Expected results:
Mouse unlocks and is no longer disabled when typing

Additional info:
running "sleep 4; xinput set-prop [id] 286 0" or similar works around the issue by having the timer expire and mouse re-enabled before the setting is changed

~ $ xinput list-props 12
Device 'SynPS/2 Synaptics TouchPad':
	Device Enabled (137):	1
	Coordinate Transformation Matrix (139):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (273):	1
	libinput Tapping Enabled Default (274):	0
	libinput Tapping Drag Lock Enabled (275):	0
	libinput Tapping Drag Lock Enabled Default (276):	0
	libinput Accel Speed (277):	0.000000
	libinput Accel Speed Default (278):	0.000000
	libinput Natural Scrolling Enabled (279):	0
	libinput Natural Scrolling Enabled Default (280):	0
	libinput Send Events Modes Available (257):	1, 1
	libinput Send Events Mode Enabled (258):	0, 0
	libinput Send Events Mode Enabled Default (259):	0, 0
	libinput Left Handed Enabled (281):	0
	libinput Left Handed Enabled Default (282):	0
	libinput Scroll Methods Available (283):	1, 1, 0
	libinput Scroll Method Enabled (284):	1, 0, 0
	libinput Scroll Method Enabled Default (285):	1, 0, 0
	libinput Disable While Typing Enabled (286):	1
	libinput Disable While Typing Enabled Default (287):	1
	Device Node (260):	"/dev/input/event5"
	Device Product ID (261):	2, 7
	libinput Drag Lock Buttons (288):	<no items>
	libinput Horizonal Scroll Enabled (262):	1
Comment 1 Peter Hutterer 2016-02-10 19:03:51 EST
doh, forgot to actually push and build yesterday. Package just hit koji, please update to 1.1.7

Note You need to log in before you can comment on or make changes to this bug.