This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 130648 - active-filter does not allow 'outbound' keyword
active-filter does not allow 'outbound' keyword
Status: CLOSED DUPLICATE of bug 128053
Product: Fedora
Classification: Fedora
Component: ppp (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-23 09:21 EDT by Enrico Scholz
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2004-08-23 09:21:46 EDT
Description of problem:

pppd fails on filter with 'outbound/inbound' qualifiers

| # pppd active-filter 'outbound'
| pppd: error in active-filter expression: inbound/outbound not
supported on linktype 0

Such kind of filter is required e.g. for idle-detection. They should
work because 'pppd' accepts the same expression like 'tcpdump':

| # tcpdump -i ppp0 'outbound' -nn
| tcpdump: verbose output suppressed, use -v or -vv for full protocol
decode


I suspect some changed behavior in the underlying libpcap: the
qualifiers are working on special devices only. On tcpdump it is given
by '-i ppp0', but with pppd, a default type will be assumed which does
not support it. But this is just a wild guess without looking at the code.


Version-Release number of selected component (if applicable):

ppp-2.4.2-3.FC2.1
libcap-1.10-18.1


How reproducible:

100%
Comment 1 Thomas Woerner 2004-08-23 09:23:15 EDT

*** This bug has been marked as a duplicate of 128053 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.