This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1306486 - Get List of Containers returns different result to native Swift
Get List of Containers returns different result to native Swift
Status: CLOSED NOTABUG
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
1.3.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.2
Assigned To: Yehuda Sadeh
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 19:31 EST by Neil Levine
Modified: 2017-07-31 16:59 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-12 13:35:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Swift results (22.01 KB, image/png)
2016-02-10 19:31 EST, Neil Levine
no flags Details
RGW results (25.60 KB, image/png)
2016-02-10 19:32 EST, Neil Levine
no flags Details

  None (edit)
Description Neil Levine 2016-02-10 19:31:36 EST
Created attachment 1123040 [details]
Swift results

According to Citrix, who have been testing Sharefile with RHCS 1.3, there is a variation in the return when listing containers between RGW and RHCS. I quote:

"We observed, there is no proper formatting/serialization and tags to the result body and we may have to write our own logic to parse the result to adapt with existing SDK. Since it is not standard, changing the internal API signatures might also break our logic."

See two attachments for variation between the Swift results and the RGW results.
Comment 1 Neil Levine 2016-02-10 19:32 EST
Created attachment 1123041 [details]
RGW results
Comment 3 Neil Levine 2016-02-23 17:34:36 EST
Comment 1 should say:

"when listing containers between RGW and Swift"

Note You need to log in before you can comment on or make changes to this bug.