Bug 1306512 - [DOCS] [3.2] Document the rolling upgrade of masters
[DOCS] [3.2] Document the rolling upgrade of masters
Status: CLOSED DUPLICATE of bug 1319486
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Alex Dellapenta
Anping Li
Vikram Goyal
:
Depends On:
Blocks: 1319486
  Show dependency treegraph
 
Reported: 2016-02-11 00:54 EST by Vikram Goyal
Modified: 2017-03-08 13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-14 21:47:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikram Goyal 2016-02-11 00:54:30 EST
In OSE 3.2, upgrades with multiple masters will be done in a rolling fashion. That is, first one master is upgraded and then the other, resulting in at least one master present at all times and therefore there is no downtime.

Trello card is:
https://trello.com/c/USvktbLP/130-3-rolling-restarts-for-masters

Dev for this feature is:
Andrew Butcher

QE for this feature is:
Anping Li

Likely Guide:
https://docs.openshift.com/enterprise/3.1/install_config/upgrades.html
Comment 1 Alex Dellapenta 2016-03-20 11:37:14 EDT
I'll handle this as part of the general 3.2 upgrade doc work (https://bugzilla.redhat.com/show_bug.cgi?id=1319486).
Comment 2 Vikram Goyal 2016-03-28 22:29:49 EDT
(In reply to Alex Dellapenta from comment #1)
> I'll handle this as part of the general 3.2 upgrade doc work
> (https://bugzilla.redhat.com/show_bug.cgi?id=1319486).

Thanks Alex. In that case, let's mark this bug as a duplicate of 1319486.
Comment 3 Vikram Goyal 2016-04-14 21:47:38 EDT

*** This bug has been marked as a duplicate of bug 1319486 ***

Note You need to log in before you can comment on or make changes to this bug.