Bug 1306542 - samba-common postun scriptlet failure
samba-common postun scriptlet failure
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Schneider
Fedora Extras Quality Assurance
:
: 1307040 1308485 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 04:04 EST by Ralf Corsepius
Modified: 2016-02-15 08:10 EST (History)
11 users (show)

See Also:
Fixed In Version: samba-4.4.0-0.4.rc2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-15 08:10:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2016-02-11 04:04:57 EST
Description of problem:

On a rawhide system, I encountered this during a dnf update:

# dnf update
...
 Cleanup     : samba-common-2:4.4.0-0.0.rc1.fc24.noarch                                                                       64/89 
/sbin/ldconfig: relative path `1' used to build cache
warning: %postun(samba-common-2:4.4.0-0.0.rc1.fc24.noarch) scriptlet failed, exit status 1
Non-fatal POSTUN scriptlet failure in rpm package samba-common
Non-fatal POSTUN scriptlet failure in rpm package samba-common


Version-Release number of selected component (if applicable):
samba-common-2:4.4.0-0.0.rc1.fc24.noarch

How reproducible:
Always

Steps to Reproduce:
This issue is reproducible in mock:
1. mock -r fedora-rawhide-x86_64 --install dnf samba-common
2. mock -r fedora-rawhide-x86_64 --shell
3. dnf reinstall samba-common

Actual results:
cf. above

Expected results:
Function, no warning.

Additional info:

Seems to me as if the %postuninstall scriptlet is infected with shell code:

# rpm -q --scripts samba-common
...
postuninstall scriptlet (using /sbin/ldconfig):


### KRB5-PRINTING

I.e. rpm tries to run a script which is containing a /bin/sh-style comment
(### KRB5...) using /sbin/ldconfig as shell-interpreter.
Comment 1 Guenther Deschner 2016-02-11 04:52:38 EST
Andreas, could you please have a look?
Comment 2 Alexander Bokovoy 2016-02-12 09:44:27 EST
*** Bug 1307040 has been marked as a duplicate of this bug. ***
Comment 3 Alexander Bokovoy 2016-02-15 07:49:46 EST
*** Bug 1308485 has been marked as a duplicate of this bug. ***
Comment 4 Andreas Schneider 2016-02-15 08:10:00 EST
Fixed with samba-4.4.0-0.4.rc2.fc24

Note You need to log in before you can comment on or make changes to this bug.