Bug 1306574 - email notifications are not sent from nagios server which is installed on one of the RHGS nodes
email notifications are not sent from nagios server which is installed on one...
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nagios-server-addons (Show other bugs)
3.1
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ramesh N
RHS-C QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 05:31 EST by Triveni Rao
Modified: 2016-05-16 00:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 23:54:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Triveni Rao 2016-02-11 05:31:56 EST
Description of problem:
=======================
email notifications are not sent from nagios server which is installed on one of the RHGS nodes
Even though all the related stpes are completed to configure mail notifications on the nagios server, mails are not received.

Troubleshoot:
============

when the same email command was executed from the command line below error was seen,
[root@casino-vm1 gluster]# /usr/bin/printf "%b" "***** Nagios *****\n\nNotification Type: $NOTIFICATIONTYPE$\nHost: $HOSTNAME$\nState: $HOSTSTATE$\nAddress: $HOSTADDRESS$\nInfo: $HOSTOUTPUT$\n\nDate/Time: $LONGDATETIME$\n" | /bin/mail -s "** $NOTIFICATIONTYPE$ Host Alert: $HOSTNAME$ is $HOSTSTATE$ **" $CONTACTEMAIL$
[root@casino-vm1 gluster]# send-mail: fatal: parameter inet_interfaces: no local interface found for ::1

After googling it was found that this was an issue with postfix service.

https://access.redhat.com/solutions/1591423

https://access.redhat.com/solutions/8709

after disabling IPv6 on the node emails were received.

Note: Similar kind of issue was seen on RHEL7.2 RHGS3.1.2 node but after using postfix and starting postfix service resolved the issue.


Version-Release number of selected component (if applicable):
=============================================================
nagios-server-addons-0.2.3-1.el6rhs.noarch

RHGS version : 3.1.2 based on RHEL6.7

How reproducible:
===================
easily

Steps to Reproduce:
===================
1.install RHGS3.1.2 RHEL6.7 and install Nagios-server-addons
2.configure nagios and configure email notification
3. send notification from one of the services on nagios UI


Actual results:
==============
no emails received.


Expected results:
================
emails shoud be sent properly.

Additional info:
Comment 2 Sahina Bose 2016-02-23 23:54:54 EST
Since this is an issue with the mail service used, closing it not a bug in this component. 
Before configuring email notifications on nagios server, user is expected to test the mail configuration. The KB article referenced in Comment 1 can be used to fix issue with postfix

Note You need to log in before you can comment on or make changes to this bug.