Bug 1306581 - Update geo-replication checkpoint with new command output
Update geo-replication checkpoint with new command output
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-Administration_Guide (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity high
: ---
: RHGS 3.1.2
Assigned To: Divya
Rahul Hinduja
: Documentation, ZStream
: 1306580 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 06:04 EST by Divya
Modified: 2017-11-17 00:31 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Divya 2016-02-11 06:04:27 EST
Update geo-replication checkpoint with new command in the following sections:

- ⁠13.6.2. Failover and Failback

- ⁠10.4.1. Shrinking a Geo-replicated Volume


Document URL: 

Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

Additional information: 


Document URL: 

Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

Additional information:
Comment 3 Rahul Hinduja 2016-02-12 02:03:49 EST
There is the change in the command output for checkpoint status detail:

Older of showing the checkpoint:

* Monitor the checkpoint output using the following command, until the status displays: checkpoint as of checkpoint as of <time of checkpoint creation> is completed at <time of completion>.
 
# gluster volume geo-replication MASTER_VOL SLAVE_HOST::SLAVE_VOL status detail 

Should be changed to:

* Use the following command to verify the checkpoint completion for geo-replication session: 

 # gluster volume geo-replication MASTER_VOL SLAVE_HOST::SLAVE_VOL status detail

Impacted sections are:

- ⁠13.6.2. Failover and Failback

- ⁠10.4.1. Shrinking a Geo-replicated Volume

- Issues related to geo-replication #BZ#1286587
Comment 4 Divya 2016-02-19 03:37:00 EST
Updated the following sections with the new geo-replication checkpoint command output:

- ⁠13.6.2. Failover and Failback

- ⁠10.4.1. Shrinking a Geo-replicated Volume

Link tot he latest doc: http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-3.1-Administration_Guide%20%28html-single%29/lastStableBuild/artifact/tmp/en-US/html-single/index.html
Comment 5 Rahul Hinduja 2016-02-23 08:35:11 EST
(In reply to Divya from comment #4)
> Updated the following sections with the new geo-replication checkpoint
> command output:
> 
> - ⁠13.6.2. Failover and Failback
> 
> - ⁠10.4.1. Shrinking a Geo-replicated Volume
> 
> Link tot he latest doc:
> http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-
> 3.1-Administration_Guide%20%28html-single%29/lastStableBuild/artifact/tmp/en-
> US/html-single/index.html

For Shrinking a geo-replicated volume: 

Command In doc mentioned is 

# gluster volume geo-replication MASTER_VOL SLAVE_HOST::SLAVE_VOL status

Whereas, it should be

# gluster volume geo-replication MASTER_VOL SLAVE_HOST::SLAVE_VOL status detail as mentioned in comment 3

Also, can you please let me know the link for known issues which needs to be updated as mentioned in comment 3
Comment 6 Divya 2016-02-24 02:10:27 EST
(In reply to Rahul Hinduja from comment #5)
> (In reply to Divya from comment #4)
> > Updated the following sections with the new geo-replication checkpoint
> > command output:
> > 
> > - ⁠13.6.2. Failover and Failback
> > 
> > - ⁠10.4.1. Shrinking a Geo-replicated Volume
> > 
> > Link tot he latest doc:
> > http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-
> > 3.1-Administration_Guide%20%28html-single%29/lastStableBuild/artifact/tmp/en-
> > US/html-single/index.html
> 
> For Shrinking a geo-replicated volume: 
> 
> Command In doc mentioned is 
> 
> # gluster volume geo-replication MASTER_VOL SLAVE_HOST::SLAVE_VOL status
> 
> Whereas, it should be
> 
> # gluster volume geo-replication MASTER_VOL SLAVE_HOST::SLAVE_VOL status
> detail as mentioned in comment 3

I have updated the command. Link to the doc: http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-3.1-Administration_Guide%20%28html-single%29/lastStableBuild/artifact/tmp/en-US/html-single/index.html#idm139713906477744


> Also, can you please let me know the link for known issues which needs to be
> updated as mentioned in comment 3

Regarding BZ#1286587, Laura (lbailey@redhat.com) is documenting the known issues for 3.1.2 release. Please update the doc text and put need_info on Laura to modify the Release Notes.
Comment 7 Rahul Hinduja 2016-02-24 02:33:30 EST
Verified the above link. Changes looks good to me. Moving this bug to verified state
Comment 8 Divya 2016-03-03 02:08:28 EST
*** Bug 1306580 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.