Bug 1306593 - Missing dependency on perl(Test::More)
Missing dependency on perl(Test::More)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Gtk2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 07:00 EST by Petr Pisar
Modified: 2016-02-11 10:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-11 10:17:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-02-11 07:00:57 EST
Perl Gtk2 packages like perl-Gtk2-TryIcon or perl-Gtk2-Sexy fail to build because perl-Gtk2 does not run-require perl(Test::More):

Can't locate Test/More.pm in @INC (you may need to install the Test::More module) (@INC contains: /builddir/build/BUILD/Gtk2-TrayIcon-0.06/blib/lib /builddir/build/BUILD/Gtk2-TrayIcon-0.06/blib/arch /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/lib64/perl5/vendor_perl/Gtk2/TestHelper.pm line 8.

This is because perl-Gtk2 explicitly filters Test and Glib from requires:

%global __requires_exclude perl\\(Glib\\)|perl\\(Test::

The filter must be removed.

If the motivation is that any Perl Gtk2 application would pull in Test::More, then the solution is to move the Gtk2::TestHelper into a subpackage.

If you don't object I can do it.

Tested with perl-Gtk2-1.2498-1.fc24.x86_64.
Comment 1 Tom "spot" Callaway 2016-02-11 10:17:49 EST
I've removed the filter in rawhide (perl-Gtk2-1.2498-2.fc24). Let me know if we need to push this change out to stable branches.

Note You need to log in before you can comment on or make changes to this bug.