Bug 130684 - dhcp erasing resolv.conf
Summary: dhcp erasing resolv.conf
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-23 18:14 UTC by Havoc Pennington
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: initscripts-7.67-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 19:00:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:566 normal SHIPPED_LIVE Updated dhcp and dhclient packages 2005-05-26 04:00:00 UTC

Description Havoc Pennington 2004-08-23 18:14:14 UTC
When bringing up an interface with BOOTPROTO=dhcp, resolv.conf gets
its contents deleted (there's an empty resolv.conf with some
whitespace in it)

Comment 1 Jason Vas Dias 2004-08-23 18:40:00 UTC
Please tell me: what version of initscripts & dhcp do you have ?
Was did the DHCP interface brought up - ie. did you get a lease ?
I can't duplicate this with initscripts-7.66 + dhcp-3.0.1-7.


Comment 2 Jason Vas Dias 2004-08-23 19:00:01 UTC
AHA ! This happened due to initscripts-7.66 update I made Friday
if pre-existing /etc/resolv.conf is non-existent or empty - this
typo is now fixed in initscripts-7.67-1 - SORRY!


Comment 3 John Flanagan 2004-12-21 19:41:48 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-566.html



Note You need to log in before you can comment on or make changes to this bug.