Bug 1306940 - SELinux is preventing plugin-containe from 'name_bind' accesses on the tcp_socket port 5445.
SELinux is preventing plugin-containe from 'name_bind' accesses on the tcp_so...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
24
x86_64 Unspecified
high Severity high
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:3fd8054befb45617fe2b533e8ad...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 03:59 EST by Vít Ondruch
Modified: 2016-08-18 07:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-18 07:38:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2016-02-12 03:59:39 EST
Description of problem:
SELinux is preventing plugin-containe from 'name_bind' accesses on the tcp_socket port 5445.

*****  Plugin mozplugger (82.0 confidence) suggests   ************************

If you want to use the plugin package
Then you must turn off SELinux controls on the Firefox plugins.
Do
# setsebool -P unconfined_mozilla_plugin_transition 0

*****  Plugin catchall_boolean (9.19 confidence) suggests   ******************

If you want to allow mozilla to plugin bind unreserved ports
Then you must tell SELinux about this by enabling the 'mozilla_plugin_bind_unreserved_ports' boolean.
You can read 'None' man page for more details.
Do
setsebool -P mozilla_plugin_bind_unreserved_ports 1

*****  Plugin catchall_boolean (9.19 confidence) suggests   ******************

If you want to allow mozilla to plugin use bluejeans
Then you must tell SELinux about this by enabling the 'mozilla_plugin_use_bluejeans' boolean.
You can read 'None' man page for more details.
Do
setsebool -P mozilla_plugin_use_bluejeans 1

*****  Plugin catchall (1.58 confidence) suggests   **************************

If you believe that plugin-containe should be allowed name_bind access on the port 5445 tcp_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                system_u:object_r:jboss_messaging_port_t:s0
Target Objects                port 5445 [ tcp_socket ]
Source                        plugin-containe
Source Path                   plugin-containe
Port                          5445
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-171.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.4.0-1.fc24.x86_64 #1 SMP Mon Jan
                              11 16:48:24 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2016-02-12 09:44:34 CET
Last Seen                     2016-02-12 09:44:34 CET
Local ID                      28977d8e-1390-4668-b28a-775250e6eced

Raw Audit Messages
type=AVC msg=audit(1455266674.259:385): avc:  denied  { name_bind } for  pid=3677 comm="plugin-containe" src=5445 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:jboss_messaging_port_t:s0 tclass=tcp_socket permissive=0


Hash: plugin-containe,mozilla_plugin_t,jboss_messaging_port_t,tcp_socket,name_bind

Version-Release number of selected component:
selinux-policy-3.13.1-171.fc24.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.4.0-1.fc24.x86_64
type:           libreport
Comment 1 Lukas Vrabec 2016-02-15 06:56:16 EST
*****  Plugin catchall_boolean (9.19 confidence) suggests   ******************

If you want to allow mozilla to plugin use bluejeans
Then you must tell SELinux about this by enabling the 'mozilla_plugin_use_bluejeans' boolean.
You can read 'None' man page for more details.
Do
setsebool -P mozilla_plugin_use_bluejeans 1
Comment 2 Vít Ondruch 2016-02-23 06:09:15 EST
$ setsebool -P mozilla_plugin_use_bluejeans 1
Cannot set persistent booleans, please try as root.

$ sudo setsebool -P mozilla_plugin_use_bluejeans 1
Boolean mozilla_plugin_use_bluejeans is not defined
Comment 3 Jan Kurik 2016-02-24 09:30:40 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 4 Lukas Vrabec 2016-02-25 09:45:29 EST
Hi, 
A tried this on my Rawhide system and it looks fine. Could you reinstall selinux-policy package?
Comment 5 Vít Ondruch 2016-03-02 09:24:53 EST
The "$ sudo setsebool -P mozilla_plugin_use_bluejeans 1" worked this time. Will see next time I try to use BJ if the problem is resolved.
Comment 6 Lukas Vrabec 2016-08-18 07:38:32 EDT
Closing as NOTABUG, issue was fixed by boolean.

Note You need to log in before you can comment on or make changes to this bug.