Bug 130697 - No TrueType printing from within epiphany
No TrueType printing from within epiphany
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2004-08-23 15:34 EDT by Joachim Frieben
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-31 15:36:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2004-08-23 15:34:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803 Epiphany/1.2.7

Description of problem:
Trutype rendering is superbly implemented in the GNOME desktop
environment and 'epiphany' is no exception in this respect. However,
despite the beautifully rendered on-screen web pages, printing output
is pretty poor. In this case, 'epiphany' actually falls back to using
plain PS fonts.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install some cute TrueType fonts available for GNOME.
2. Watch epiphany render a suitable web page using them.
3. Print the web page ... .

Actual Results:  Printer output is way different from what is seen on
the screen.

Expected Results:  Printer output should correspond to the screen image.

Additional info:
Comment 1 Matthew Miller 2005-04-26 12:16:52 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 2 Joachim Frieben 2005-04-29 01:55:41 EDT
Still no truetype printing in epiphany-1.6.1-2.
Comment 3 Joachim Frieben 2005-09-10 04:35:43 EDT
After rebuilding "epiphany-1.8.0-1" from the development tree for FC4,
"epiphany" uses the GNOME printing interface. I always hoped, that this
change was finally going to provide truetype printing as for other GNOME
applications such as "abiword". However, after printing some test pages,
the output still looks very much like the previous plain mozilla like
Postscript output. I remember that "xprint" support in FC was denied as
the developers preferred the genuine GNOME printing support.
Moreover, the printing quality is quite bad, e.g. Pictures get printed
over by text, etc.
Comment 4 Joachim Frieben 2005-12-04 13:47:13 EST
Still no truetype printing with epiphany-1.9.2-1.
Comment 5 Joachim Frieben 2005-12-12 12:20:05 EST
Due to lack of any activity for more than 1 year, I have submitted an
equivalent bug report at:

Comment 6 Joachim Frieben 2006-01-09 03:52:22 EST
Still no truetype printing with epiphany-1.9.4-1.
Comment 7 Joachim Frieben 2006-02-20 15:41:58 EST
Still no truetype printing with epiphany-1.9.7-1.
Comment 8 Joachim Frieben 2006-02-22 04:42:53 EST
According to Comment #5 of Bug #112879, the issue is due to an outdated
"gecko" backend. Current version is 1.7, but improved font rendering is
only implemented in version 1.8.
I checked against current "firefox-" from the "rawhide" tree.
As a matter of fact, here, "TrueType" printing works out of the box
(without "xprint" etc.). Other distros build "epiphany" against "firefox"
which allows the former to benefit from the more recent "gecko" backend
of the latter. Please upgrade the "gecko" backend in current Fedora
Comment 9 Joachim Frieben 2006-05-07 14:42:00 EDT
Still no truetype printing with "epiphany-2.14.1-1". The "gecko" backend
is still version 1.7. One possible solution is to build "epiphany"
against "xulrunner". Any schedule for pushing this component into
Comment 10 Joachim Frieben 2006-05-09 10:27:40 EDT
After working around Bug #191150, Bug #191153, Bug #191154, and
Bug #191167, it is possible to rebuild "epiphany-2.14.1-3" against
a modified "xulrunner-1.8.0.cvs20060505-1". The package manager
complains: "error: Failed dependencies: libxul.so is needed by
epiphany-2.14.1-4.i386", but after forcing the installation of the
package (cough..), "epiphany" works, and TrueType printing is up
and running!
Comment 11 Joachim Frieben 2006-07-31 15:36:56 EDT
Ok, fixed in "epiphany-2.15.4-1" thanks to "firefox" backend.

Note You need to log in before you can comment on or make changes to this bug.