Bug 1307020 - xrandr cannot set custom resolution
xrandr cannot set custom resolution
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 08:14 EST by Robert Smol
Modified: 2016-04-13 16:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 16:00:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Smol 2016-02-12 08:14:41 EST
Description of problem:

xrandr cannot set 2560x1440_44hz resolution. Basically I have monitor with 2560/1440 resolution and my card does not support this at 60hz. I always used this trick:

~ $ cvt 2560 1440 44
# 2560x1440 43.99 Hz (CVT) hsync: 65.06 kHz; pclk: 222.75 MHz
Modeline "2560x1440_44.00"  222.75  2560 2720 2992 3424  1440 1443 1448 1479 -hsync +vsync
~ $ xrandr --newmode "2560x1440"  222.75  2560 2720 2992 3424  1440 1443 1448 1479  -HSync +Vsync
~ $ xrandr --addmode HDMI1 2560x1440
~ $ xrandr --output HDMI1 --mode 2560x1440


And it worked, but for some time now it only flickers and goes back to different resolution. It does not produce any error so I can't figure out whoat is wrong.

Monitor: DELL U2515H
Card: Intel-HD-Graphics-4000


Version-Release number of selected component (if applicable):
Fedora 23, up-to-date, 4.3.5-300.fc23.x86_64
~ $ rpm -qa|grep intel
xorg-x11-drv-intel-2.99.917-16.20150729.fc23.x86_64
libva-intel-driver-1.6.2-1.fc23.x86_64
~ $ rpm -qa|grep xorg-x11-server
xorg-x11-server-Xwayland-1.18.0-2.fc23.x86_64
xorg-x11-server-common-1.18.0-2.fc23.x86_64
xorg-x11-server-Xorg-1.18.0-2.fc23.x86_64
xorg-x11-server-utils-7.7-17.fc23.x86_64

How reproducible:

See in description

Steps to Reproduce:
1.xrandr --newmode "2560x1440"  222.75  2560 2720 2992 3424  1440 1443 1448 1479  -HSync +Vsync
2.xrandr --addmode HDMI1 2560x1440
3. xrandr --output HDMI1 --mode 2560x1440


Actual results:

monitor flashes and reverts back

Expected results:

sets required resolution

Additional info:
journalctl -fe _COMM=gdm-x-session
úno 12 14:04:35 fedora-laptop /usr/libexec/gdm-x-session[2470]: (II) intel(0): resizing framebuffer to 2560x1440
úno 12 14:04:35 fedora-laptop /usr/libexec/gdm-x-session[2470]: (II) intel(0): switch to mode 2560x1440@44.0 on HDMI1 using pipe 1, position (0, 0), rotation normal, reflection none
úno 12 14:04:35 fedora-laptop /usr/libexec/gdm-x-session[2470]: (II) intel(0): resizing framebuffer to 2048x1152

not sure if it helps, but I get this sometimes in dmesg
[10282.224445] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
Comment 1 Robert Smol 2016-04-13 16:00:45 EDT
I've change laptop and cannot reproduce this bug anymore.

Note You need to log in before you can comment on or make changes to this bug.